This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Bobby 6 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
March 27, 2019 at 6:55 pm

niekL

I am trying to: use language directory instead of parameter. But now I have both.

Link to a page where the issue can be seen:hidden link

I expected to see: hidden link

Extra info;
I needed to restore this site from a 15month old backup. So I need to upgrade the Impreza theme (from 3.3 to 5.8), most of the plugins and also WP5.1. That is all done now.
Then I also tried to change Language parameter to language directory.
Some page were made as duplicate, which I don't like and changed to translation.

So now I have issues with most of the language pages.
-The frontpage is not displaying in FR
-Some page url's are partly translated like this: hidden link The last part of the url is still dutch, but in the backend I see the Title is translated. Also on this page the Menu (FR) is lost.

March 27, 2019 at 8:19 pm #3475329

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

1. When you go to hidden link and then click on one of the options i can see that the link includes the parameters.

These links are adding within the nos-services page and then the URL is added.

go to the nos-services page->edit the service option and review the URL link, i edit it and then re search the page you are linking and it pulls the correct permalink

( i have fixed the Couverture du toit link for you)

this seems to have been caused by using an old version of the site , you will need to update these links , or you can even try using our plugin "STICKY LINKS "

manually changing them works as expected

-> https://wpml.org/account/downloads/
-> https://wpml.org/documentation/getting-started-guide/sticky-links/

2. Your translations of the home page are not working because they are in the trash, please review your trash and make sure to empty them or restore your translations

March 28, 2019 at 10:46 am #3479697

niekL

It looks like page nos-services has both a translation and a duplicate. I like to work with translation but earlier I guess it was wrongly made up with duplicate pages.
So where do I need to adjust the links? In the translation edit everything looks OK, but still the permalinks in FR show Dutch text.

About the frontpage, indeed I deleted a duplicate page, I had kmc ans kmc-3, I only need kmc with a FR translation. Again I think there is here aswell a duplicate and a translation.

How can I solve these issues?

And please have a lok at the menu in FR too, it disappears.

March 28, 2019 at 5:38 pm #3484503

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

1. If you delete any pages please make sure that you empty the trash as that causes issues

2. Go to Nos services page and edit it in the WP Editor using the pagebuilder.
to dot this either go with the link here hidden link and then click on "edit anyway"

then edit the links for the icon box settings and update the page.

the links in the icon boxes include the permalink , this is wrong. You need to remove the permalink as your links should only by hidden link

ideally you need to go through all your hardcoded links and change them by removing the permalink , this has happened due to your migration most likely, and this needs to be done in the page builder view editor

i have shared screenshots in my previous post

for your menu you need to go to Theme Options->Header->Edit default language header and then switch to the secondary language from there and edit this too in the WP Editor with the page builder and overwrite with the default language content, to keep the layout and then translate accordingly

i suggest to make all these changes using the page builder editor , i have fixed the French version for you.

March 29, 2019 at 4:56 pm #3493163

niekL

I understand what you say, that I need to edit all url's in the Page builder.
I had a try on page nos service, I can selected the Page in the link module, I see the French titel, but the actual link remains with dutch pagetitle in it, like this one hidden link
although the nos-services page in it is OK.

March 29, 2019 at 5:33 pm #3493419

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I see what you are referring to

please go here hidden link (just edit the page in the language desired to change the permalink)

afterwards you should be able to click "edit" next to the permalink and correct it

let me know your results

March 29, 2019 at 6:01 pm #3493699

niekL

OK that is working.
I found it confusing that I need to use the page builder to edit a page in a second language?
I like to work with translation not duplicates. I suppose this practice is only needed to correct the issues I have?
When I edit a page like this, does the page become a duplicate then? What with futur modifactions to the original pages, will these also be on the translated page then?

March 29, 2019 at 7:20 pm #3494237

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Its not a duplicate unless you have created it to be one by clicking on "duplicate" and even then once the translation is added the synchronization stops

since there are some minor issues such as the permalinks , hardcoded links , etc

these are best to be fixed in the page builder view as that way you have full access and it should not cause any issues in the future

April 1, 2019 at 9:31 am #3505917

niekL

I've got the FR url OK now, thanks to you advice.
I found one more issue on page Contact. in the Gravity form there I have some extra text in a HTML section. This text don't some show up in the normal Translation editor. I can find it String Translation but there I'm not able to enter translation text, it seems dimmed somehow?
The text contains 'privacywetgeving die op 25/05/18'.
So how can I translate this?

April 1, 2019 at 9:30 pm #3511833

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Within String translation this is an expected behavior , just go ahead and input your own translation within the box and then click on " Translation is complete" and save.

i have added the text there now you just have to translate it

April 4, 2019 at 2:07 pm #3535673

niekL

I also have a problem with Portfolio.
In Dutch (main) all OK, but in FR some photos don't show up. You can see it here hidden link

Let's try to narrow this down a bit, when I'm in the backend (Dutch), Portfolio, Portfolio Pages, I sort on Title, then on page 2, there are 4 portfolios with name Gevelbekleding, all 4 have feat image, but 2 are not showing in French.
2 of them are only linked to 1 category and these 2 have only 1 field to translate when I click the pencil for French. The other 2 have 2 fields, and these 2 are not showing. Is that related somehow?
In the live view you see these on page (FR) Realisations and then tab Façade.

April 4, 2019 at 4:42 pm #3537041

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

as we do try to keep each ticket to 1 issue at a time , and the original issue of the ticket has been resolved if possible please open a new ticket for the new issue regarding the portfolio

Kind Regards,
Bobby