This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Radu 6 months ago.

Assigned support staff: Radu.

Author Posts
April 18, 2019 at 8:46 pm

AlvaroP-7

I am trying to:
I have categories which I access through an url. For example: "/news". This one has a russian translation "/ru/newsrussian", but if I try to access the url without the prefix "ru", for example: "/newsrussian", it lets me access but doesn't redirect to "/news". Is there any way to fix that?

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link

Instead, I got:
Links with problems and rare redirections that we have not been able to correct

April 19, 2019 at 4:51 am #3643639

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alvaro,

Thank you for reaching out the WPML support!

As I understand, you want to get rid of the /ru/ part of the link that indicates the language of that page. There's no option to do this kind of change, at least for now. Also, having that part in the URL is a good SEO practice too. This way, the search engines will index your website in all the languages and will get a better position in the search results.

Regards,
Radu

The topic ‘[Closed] I have categories which I access through an url. For example: "/news". This one’ is closed to new replies.