This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.52 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
September 27, 2019 at 6:32 pm #4656365

anshulA-3

I have Easyengine installed with wordpress , need nginx configuration so that i can make Different languages in directories in the languages to work currently its showing message

It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses hidden link it gets:
HTTP code: 404 (Not Found)

The expected value is:
<!--hidden link;

Please help me what to make changes in the nginx config file or any other changes to make it work

September 28, 2019 at 7:02 am #4658057

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Maybe it will be a false alarm. So please try the following steps and check the issue is existing.

1) Go to WPML>>Languages>>Language URL format
2) Choose *Different languages in directories* option and save the changes
3) Visit Setttings>>Permalinks
4) Resave the settings

Also please make sure you are following General WordPress rules for Nginx - https://wordpress.org/support/article/nginx/

I have a request. Please upgrade the following configuration for the better performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

The topic ‘[Closed] I have Easyengine installed with wordpress , need nginx configuration’ is closed to new replies.