This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by kumikoO 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 16, 2019 at 11:23 am

kumikoO

I am trying to:

set up Current content language, but no language options are in the dropdown lists.

April 16, 2019 at 11:47 am #3621633

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

There are some memory limit issues that I can see in the backend (I will also attach a screenshot).

Your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

The PHP memory limit should be raised too, so I suggest that you get in touch with the hosting support team and let them know about this.

Please let me know if that solves the issue.

Kind regards,
Mihai Apetrei

April 16, 2019 at 12:57 pm #3622193

kumikoO

Hello Mihai,

Thank you for the information. I have followed your instruction, but had the same issue, so I reinstalled the WPML plugin. Unfortunately I can see the same issue. Please help.

While waiting your reply, I just tried to use another theme (bethem) on my local machine and it is working well.

So the issue I am having here is to do with Bridge theme.

Best wishes

April 17, 2019 at 7:01 am #3627577

kumikoO

Hi Mihai,

Any news?

Many thanks

April 17, 2019 at 7:49 am #3628003

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I was running a good amount of troubleshooting processes yesterday but with no luck in finding what is causing the issue.

It seemed to me that somehow it was server related and as I entered right now on the site, it seems that things are working just fine:
hidden link

I will also attach a screenshot.

Maybe there was some cache running on the server or did you make any change on the server?

Please let me know and confirm if things are ok now. 🙂

Kind regards,
Mihai

April 17, 2019 at 8:53 am #3628827

kumikoO

Hi Mihai,

Thank you so much! You saved my day.
I did not anything rather than ask the hosting company to change the PHP memory limit.

Just one more thing, is this conversation in public or private? I was so rush yesterday and did not check. I would rather to be in private.

Many thanks

April 17, 2019 at 12:33 pm #3630759

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am so happy to find that the memory limit was the issue and that now it has been solved 🙂

Regarding our conversation, due to our policy, all the conversations are public but be are automatically hiding any kind of link (you can check this page from an incognito window ar without being logged in).

If you want me to also remove any screenshot, too, if you find it showing information that you don't want, please let me know and I will be happy to remove it.

Kind regards,
Mihai

April 17, 2019 at 1:01 pm #3630977

kumikoO

Hi Mihai,

Thank you so much for the information.
Please remove the screenshots and my name. I believe the private message is in private, correct?

Best wishes

April 17, 2019 at 1:13 pm #3631071

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, the private message containing the credentials is private (you can check this page from an incognito window ar without being logged in).

I removed your name and the screenshots that were containing the name of the site.

Can you also please mark this ticket as resolved? 🙂

Thank you!

Kind regards,
Mihai

April 17, 2019 at 1:45 pm #3631443

kumikoO

Thank you so much for your help. Have a lovely afternoon.