This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by anteT-2 1 month ago.

Assigned support staff: Andreas W..

Author Posts
September 9, 2019 at 1:52 pm #4537739

anteT-2

I am trying to: I have installed and activated WPML Translation Management plugin, but I cannot see it in Admin Panel. I have Multilingual agency license.

Link to a page where the issue can be seen:

hidden link

I expected to see:

Instead, I got:

September 9, 2019 at 9:55 pm #4540299

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I can see that your version of CMS Multilingual among other plguins are updated.

Please download the latest versions of WPML Multilingual CMS 4.2.8 at https://wpml.org/downloads.

Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.8 again.

Then go to Plugins -> Install -> Commercial and click "Search for updates". Then download our add-ons and necessary glue plugins. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

Please let me know if the issue has been resolved.

Kind regards
Andreas

September 10, 2019 at 1:12 pm #4545609

anteT-2

Hi,

I have followed the steps and I can now see WPML Translation Management plugin.
However, I'm not being able to translate the page. When I choose the 'Translate to German' option for a page, the translation editor is not opened, so I'm not really sure how to translate.

BR,
Ante

September 10, 2019 at 5:52 pm #4547911

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

It seems we are having currently an issue with the automatic update process on some sites.

Can you please, try a manual update via FTP? Here is how:

1 - Download the mentioned plugin zip folders from your wpml.org account.

2 - Unzip them and upload the unzipped folder to your host wp-content/plugins folder replacing the current folders.

Note: I recommend you to delete the current plugin folders before updating the new ones. Also it is better if you put your website in a maintenance mode to avoid any issue for your users.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the workaround solved the issue.

Kind regards
Andreas

September 12, 2019 at 1:29 pm #4561243

anteT-2

Hi,

I have tried what you suggested, but I got the same results.

BR,
Ante

September 12, 2019 at 9:25 pm #4564369

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 16, 2019 at 5:16 pm #4582833

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the provided credentials, but when trying to log-in it says that the username is invalid.

Could you please verify the information and edit the private message provided earlier?

Leave me a short notification.

Kind regards
Andreas

September 16, 2019 at 5:47 pm #4583007

anteT-2

Hi,

I have updated the username, please try again.

Thanks,

September 16, 2019 at 6:04 pm #4583085

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The plugins CMS Multilingual, Translation Management and String Translation are now installed and ready to use.

Register WPML and add additional components at Plugins -> add new -> commercial.

Let me know if you need further assistance.

Kind regards
Andreas

September 17, 2019 at 8:15 am #4586267

anteT-2

Hi,

can you please do the same on the live site? I will give you the credentials, just please ensure the secure form.

Thanks,

September 17, 2019 at 3:18 pm #4589617

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sure, let me see. Actually I only downloaded the latest versions and installed them by uploading them to Plugins -> Add new.

The private box is enabled.

Kind regards
Andreas

September 17, 2019 at 7:27 pm #4590787

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

The access to wp-login did not ask me for any additional password and when trying to log in it tells me that the password is incorrect.

Could you please verify? You also can edit the earlier provided credentials.

Now, if you are already using Translation Management 2.8.7 then possibly the issue is that another component is not updated.

The provided system information shows:

WPML Multilingual CMS 4.0.8
WPML String Translation 2.8.8
WPML Translation Management 2.8.6.2

All those plugins are outdated.

Please disable and delete the plugins. Then go to https://wpml.org/account/downloads/

Download the latest versions and upload them at Plugins -> Add new.

You should actually only need to download CMS Multilingual 4.2.8 and install and acitvate it. Then go to Plugins -> Add new -> Commercial and click "Search for updates".

Now, add the latest versions for Trnaslation Management, String Translation, a.s.o..

This should solve the issue. Let me know if it worked out or simply verify the credentials in order for me to have a look at the site.

Kind regards
Andreas

September 17, 2019 at 8:05 pm #4590927

anteT-2

Hi,

I have updated all plugins and now it's working, I have translated the page.

But I cannot see the language flag for German on the menu, there's only English flag.
I went to WPML>Languagues and there I can see on the Preview German flag, but there is not German flag on the website switcher.

Thanks,

September 17, 2019 at 8:45 pm #4590993

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see you translated the following page:

hidden link

The language switcher is showing up as dropdown and working as expected. When hovering the mouse cursor pver the flag the German flag will appear in the dropdown. The redirtect is working correctly.

The language switcher will only show up for pages and posts that have been translated already.

Kind regards
Andreas

September 19, 2019 at 9:44 am #4603145

anteT-2

All clear now. Thank you!