This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 1 month, 1 week ago.

Assigned support staff: Itamar.

Author Posts
February 25, 2020 at 1:24 pm #5562659

albaB

The dropdown list showed in the attached image is not showed on my current installation.

February 25, 2020 at 2:49 pm #5563319

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks a lot for reporting this issue.

I can see it also on my test site with all the latest versions of WPML and its add-ons.
But the language dropdown list is not completely disappeared in my case. I can see it at the bottom of the screen. Please see the attached screenshot.
Do you also see it there?

In any case, we have a workaround for this issue. Here it is.

1. In Settings -> Permalinks insert the slug's base in the language that you need.
2. Go to WPML -> String Translation.
3. Search for this slug. It will be available under the WordPress domain. The Name, for example, will be URL product_cat tax slug if it is the product category.
4. Select this string and change its language.
5. Go to WooCommerce -> WooCommerce Multilingual -> Store URLs and translate the slug.

I've escalated this issue to our second tier supporters and they will report it to our developers.
I'll keep you updated here on any news regarding this issue.

Thank you for your patience.
Itamar.

February 25, 2020 at 4:39 pm #5564775

albaB

Hi,

thank you for your help, but it is not working.
1.- Yes, I see the dropdowns on the bottom of the page, but if I select "spanish" and click "save", it automatically, turns to English again.

2.- I have translate it on string translation and in Store Urls, but it does not work. The slug for product base is the same in English and Spanish (is the one included on String Translation)

February 26, 2020 at 4:02 pm #5572771

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You wrote: "1.- Yes, I see the dropdowns on the bottom of the page, but if I select "spanish" and click "save", it automatically, turns to English again."

This makes me think that you didn't follow my instructions correctly. I'm sorry if they were not clear enough. You shouldn't select 'Spanish' in Settings -> Permalinks. You should only insert the Spanish slug in the field (even if it shows that it is English. Then proceed with steps 2-5. For step 4 please read our documentation here.
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Can you please try it this way and see if it works for you?

BTW, we have an errata page published concerning this issue. Please see it here.
https://wpml.org/errata/woocommerce-multilingual-change-language-of-product-slug-base-language-switcher-option-is-at-the-bottom-of-the-page-instead-of-the-correct-place/

February 27, 2020 at 10:24 am #5577127

albaB

You are right, I didn't understand step 1. But, now, I have done every thing again and it still not working.
My original language is spanish and I want English translations.

So:
1.- in Settings -> Permaliks my product slug is "/producto/ "
2.- in WPML -> String Translation I set the language of the string "producto" to Spanish.
3.- in WooCommerce -> WooCommerce Multilingual -> Store URLs I have translated the slug.

I attach 3 screen shots

February 27, 2020 at 8:20 pm #5580905

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see this problem on your site.
Can you please let me have access so I can check the issue?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

The topic ‘[Closed] I have problems translating "product base"’ is closed to new replies.