This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
April 28, 2019 at 7:09 pm #3698827


I am trying to: Have my site translated.

Link to a page where the issue can be seen: You can see my last ticket here:

I expected to see: my website translated properly.

Instead, I got: My website not translated properly.

April 29, 2019 at 7:27 pm #3706303

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @isaac-lopezs, welcome to the WPML support Forum!

It seems that you already have a ticket for this issue with Alejandro here: - the ticket is escalated to our 2nd tier support and it's on our queue to be analyzed.

In the meantime, you can use the manual editor as a workaround to translate the website:
- Go to the edit screen of the page (original language).
- Turn off the "Use WPML's Translation Editor" on the right sidebar
- Select your editor preferences and save
- Edit the translation and save

However, if you need to use the Translation editor on the page after that, the content of the translation editor will overwrite the manual translation.

If you need more help just let me know.

All the best,

May 5, 2019 at 6:52 pm #3743713


Hi Diego, but I have already translated all my site. The problem is that the other language options don't seem to work well. Please help me! I haven't received any response and this is a paid-account.

May 6, 2019 at 2:50 pm #3750163

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)


The issue is being analyzed by our developers. It is a process that takes time, That's why the delay in responding. You can check our support policy here:

I checked the ticket again and it seems that our developers provided a workaround. Alejandro posted it here:

Could you please check?

Kind regards,