Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Pierre 5 years, 7 months ago.

Assigned support staff: Pierre.

Author Posts
July 23, 2015 at 10:38 pm #665629

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I installed the latest WooCommerce Multilingual 3.6.5 version and now I have warning messages like this one on my site:

Warning: Parameter 4 to icl_t() expected to be a reference, value given in /home/www/fsuh.fo/wp-includes/plugin.php on line 213

WCML 3.6.5 uses the new WPML API Hooks and I think this is the cause of this issue.

I will suggest to update to WPML 3.2.2 or to roll-back to WCML 3.6.4 while our dev team release a new version.

==> Please note that sites using ICanLocalize (with pending translations) should NOT upgrade now to WPML 3.2.x. More information here: https://wpml.org/2015/06/wpml-3-2-released/

We will update this thread as soon as we have a fix.

Regards,
Pierre

July 24, 2015 at 7:59 am #665821

Mihai

This was fixed and version 3.6.6 of WooCommerce Multilingual was released.
https://wpml.org/forums/topic/my-site-is-broken-after-wpml-update/page/2/#post-665787

July 25, 2015 at 11:01 am #666531

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Marking this thread as resolved.