This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by stefanv-21 3 months ago.

Assigned support staff: Noman.

Author Posts
July 17, 2019 at 9:18 am #4228045

stefanv-21

I just want to edit the pages in the normal page editor. Instead i'm being redirected to the WPML editor.

I don't want to make it more confusing than it already is for my customers. Beside that the theme uses visual composer witch is not supported in the WPML editor.

Is there a way to switch to du regular editor.

July 17, 2019 at 10:40 am #4228733

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. To enable manual translation mode, open a page that you want to translate. In the Language box, turn off WPML’s Translation Editor switch found in the Translate this Document section.
Click it and you are prompted if you want to make this change site-wide or for one post/page only.

Here is doc for more details:
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

2. Various Visual Composer modules are supported by WPML and will automatically be displayed on the Translator Editor page. Here you can see list of all supported modules:
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/#supported-modules

2.1 And here is a guide on how to make custom VC elements WPML translation editor compatible:
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
https://wpml.org/documentation/support/language-configuration-files/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 17, 2019 at 10:47 am #4228841

stefanv-21

I turned off the translation editor function. I toggled the switch located on one of the pages and selected apply to all pages. Now most of the pages are editable in the normal editor but, some pages still open in the WPML editor. They all display a Gear icon (shown in the image). Can I just disable the WPML editor all together? This is getting ridiculously complicated.

July 17, 2019 at 10:55 am #4228923

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please try to deactivate WPML Translation Management plugin and see if this resolves your issue.

Thank you

July 17, 2019 at 11:17 am #4229355

stefanv-21

Turning it off allows me to edit the pages normally. The problem is i need WPML Translation Management plugin for the woocommerce translations. The moment I turn it back on The problem is back. Now of course the data of the Translation Management is stored in the database, so there is no easy way get rid of that. All the plugins just seem to be working against each other.

July 17, 2019 at 12:04 pm #4229795

stefanv-21

I ended up disabling all the WPML’s Translation Editor. Then deleted all the translated pages. Turned the plugin back on and retranslated all the pages. Now it seems to be working. Imagine the disaster if you would have 8 languages and 200 pages. I wish you guys would make some sort of a light version of the plugin without all the fuzz. Then way it is now is to complicate and to bug sensitive.

My issue is resolved now. Thank you!