This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Bobby 1 month, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 27, 2019 at 7:06 pm #4469195

nordinA

https://wpml.org/forums/topic/500-internal-server-error-starting-to-lose-faith-in-wpml/

This was the topic, I replied too late because the problem seemed solved but the exact issue was replicated so I need to continue with the topic and reply to Bobby to see how it can be fixed. This is a very serious issue, completely taking the functionality away from WPML.

Can a moderator re-open this topic again?

https://wpml.org/forums/topic/500-internal-server-error-starting-to-lose-faith-in-wpml/

August 27, 2019 at 8:51 pm #4469621

nordinA

I can not PM Bobby the moderator directly

August 27, 2019 at 9:25 pm #4469873

nordinA

The issue only happens when I set languages by being added as a language country code behind the domain name domain.com/en domain.com/de

hidden link does not cause this issue.........

August 28, 2019 at 6:27 am #4471355

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

We can continue the ticket here

were you able to create an error log as requested in my previous reply as this could allow us to see if any fatal errors pointing to WPML are recorded ?

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.
(sometimes you have to wait a bit for the error log to be generated)

Also as mentioned before we can attempt to create a duplicator package excluding your media files to test on our local environment and/or our cloudways staging servers

please let me know if you have one available or if you would like me to create one and i can enabled the next reply to be private

August 28, 2019 at 11:11 am #4473795

nordinA

Hi, where can I send you the information? My domain is mentioned also in the last ticket when you replied JULY 31, 2019 AT 7:30 PM. You posted a piece of code https://wpml.org/forums/topic/500-internal-server-error-starting-to-lose-faith-in-wpml/

In the code is the domain name available, kindly request for you to edit your post so you can take that away.

Where can I attach the error log information to you personally? I see no way to reply here without it being public.

August 28, 2019 at 5:10 pm #4476119

nordinA

Also, is there anything I can do for faster support?

August 28, 2019 at 10:51 pm #4476997

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have enabled the private field reply, you can share with me a link to your error log as well with access to the backend of your site as i will need to create a duplicator package to further test this

the previous post has been edited to remove the domain.

Regarding the support, if you wish we could try to pair you with a different supporter that is closer to your time zone as we most likely have a difference of time zone.

please let me know if you would prefer that, what is your current time zone ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 31, 2019 at 8:02 pm #4491315

nordinA

Hi,

Any word?

September 1, 2019 at 7:14 pm #4493009

nordinA

Hi Bobby,

It has been a few days. Could you reach back to me about the situation?

I see All-in-One WP Migration plugin has been installed and activated by you. Where is the other copy of the site hosted now? I have not explicitely given permission for this, but I expect it will be deleted once the problem is solved.

Getting this major issue fixed is the most important matter. Thanks

September 3, 2019 at 7:44 am #4501747

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I would like to apologize for the wait to hear back

The All in one wp migration plugin has now been removed and it was indeed used to create a local environment of your site to test without affecting your live site

during my debugging i got the following outcomes :

1. The issue is resolved when deactivating your plugins and only leaving WPML and Woocommerce , which shows that this is not a bug within WPML plugins

2. The issue is being caused by internal redirects

[Tue Sep 03 09:56:03 2019] [error] [client ::1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: <em><u>hidden link</u></em>

you can confirm this by verifying your server logs

September 3, 2019 at 10:29 am #4503463

nordinA

Okay but that still leaves me in confusion and doesn't solve my problem. I have contacted my hosting provider regarding the server issue being caused by internal redirects. He told me the following:

This is not a server problem. The server is interfering however, because after 10 internal redirects the process is being stopped. That's because it causes a loop.

He then added this URL:

https://wpml.org/forums/topic/request-exceeded-the-limit-of-10-internal-redirects-2/

I still don't understand/know how to get this issue fixed.

September 3, 2019 at 12:28 pm #4504407

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

yes i am familiar with the ticket your host provider is linking to , but if they were to examine your .htaccess file they would see that this is not the same issue.

the issue they are linking to is due to the directory being added to .htaccess which is not the case here

here is the documentation regarding this : https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

the issue you are experiencing i have confirmed that is a redirect which is happening most likely due to your .htaccess

within your .htaccess there are a lot of custom scripts , the default .htaccess by itself is quite simple as seen here

-> https://wordpress.org/support/article/htaccess/

please review it, and let me know your results

also try the following as a test, go to WPML->languages-> switch to "Language name added as a parameter"

September 6, 2019 at 9:44 am #4524549

nordinA

I will take a look at the HTaccess and get back to you in this thread, this needs to be resolved...

September 6, 2019 at 7:06 pm #4527157

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Once done please update me here

September 8, 2019 at 7:25 am #4530691

nordinA

Ok no update or resolving of the issue, I tried taking away several components of the htaccess but doing that does not resolve the issue...I am at loss of things/ideas, I don't know how to solve this issue by myself.