Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mario Diaz 1 year, 4 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 11, 2019 at 8:29 pm #3316659

Mario Diaz

Hello
I need only translate one page hidden link This page I have to translate into Turkish that I already have the prepared text.My question is how can I add only in this page plus the translated in Turkish the flag icons? In the rest of the pages I do not want the icons of the flags to be seen.It's possible? I hope you have explained me well.

Thanks

March 11, 2019 at 9:33 pm #3316841

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. The language switcher will only appear where you have translation available, so if you have a translation only for this page the language switcher will appear only for this page, just make sure to check the option 'Skip language' from your WordPress Dashboard > WPML > Languages > Language switcher options settings. Please, let me know if you need any additional clarifications and instructions. Have a nice day.

March 13, 2019 at 12:40 pm #3333361

Mario Diaz

Hello
It is impossible for me to solve the problem. I have been trying all day and it does not work out. Even before, the 2 flags came out and now only the German one comes out.What I'm trying to do is, I just need to translate a page that I've already translated.I only need the flags on the page that I am interested in, which is in Türkisches Recht and in the translated one. Possible? Until now it is impossible for me. I even made an upgrade for if that solved the problem. I need your help

Thanks

March 13, 2019 at 7:27 pm #3337833

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, let me know to understand the details your request, you need to translate just a particular page of your website, the language switcher flags should appear for this page only and be hidden for any other page, right? In this case I need to take a look in your WordPress Dashboard in order to understand your current settings and provide you with the needed instructions and the right code to hide the language flags in the other pages. For that, please, consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 14, 2019 at 6:16 pm #3347841

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your WordPress Dashboard and noticed you are using a header builder for Divi, while there's a header template for your default language (german) there's no a translation for this header for the secondary language (turkish) and this is the reason you don't see your logo, navigation or language switcher when browsing your page translation. Please, proceed this way:

1 - Click the plus icon to add a translation for your current header template (Header & Navigation Style 2) from your WordPress Dashboard > ra-yendy.de > DU Header - Library settings.

2 - Copy the id of your translated template, you are able to see the post id in your browser address bar.

3 - Now in your WordPress Dashboard > WPML > String Translation select the 'admin_texts_divi_ultimate_header_plugin_header_styling_settings' text domain and paste the id of your header template for your Turkish translation.

4 - Don't forget to create the turkish version of you navigation, for that, please take a look at: https://wpml.org/documentation/getting-started-guide/translating-menus/

5 - As a last step you should make sure to choose the option 'Skip language' from your WordPress Dashboard > WPML > Languages > Language switcher options

Please, let me know if it helps or if you need any additional assistance. Have a nice day.

March 28, 2019 at 3:16 pm #3482995

Mario Diaz

My issue is resolved now. Thank you!