This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by carlosS-40 5 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 2, 2019 at 1:55 pm #3725145

carlosS-40

Tell us what you are trying to do?

Hi, I am running WP Multisite configuration with WPML currently configured to "Different languages in directories" and "Use directory for default language" .

I am implementing a Progressive Wep App solution in Multisite which treats different language home pages as different sites under current WPML configuration (ie /en/ different site than /es/ which is not what I want. To fix it, I can change the WPML language URL Format to "Language name added as a parameter" which will be treated as same site.

Before doing so, I want to make sure I follow best practice recommendation to avoid issues in any of the sites. I know I have to make the change in any site of the multisite for which I want to implement the change.

Please advice best practice and risks.

Thanks

May 2, 2019 at 2:26 pm #3725613

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. You can proceed with this setup in your WordPress Dashboard > WPML > Languages settings, also you will need to resave your permalinks from your WordPress Dashboard > Settings > Permalinks settings and clear any cache you might have. Please, notice changing the url formats should have some impact in your SEO strategies.

Related resources:

https://wpml.org/forums/topic/automatic-redirect-after-language-url-format-change/

https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

https://wpml.org/2010/12/whats-your-strategy-for-multilingual-seo/

Hope it helps, have a nice day.

May 2, 2019 at 6:29 pm #3728245

carlosS-40

My issue is resolved now. Thank you!