This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 4 months ago.

Assigned support staff: Itamar.

Author Posts
June 11, 2019 at 4:40 pm #3997355

richardT-24

I am trying to:
change the site domain on ams.wpml.org/panel/websites. The domain on show is for the test site domain, I want to change it to the live site domain

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link

Instead, I got:
hidden link

It is not obvious what I should do, I don't know where I would find a migration code, etc.

June 11, 2019 at 5:35 pm #3997739

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please find all the relevant information at the following link.
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/merging-and-removing-websites-from-your-advanced-translation-editor-account/
Please let me know if you have any questions about this issue.

Regards,
Itamar.

June 11, 2019 at 7:36 pm #3998305

richardT-24

Thanks for getting back to me. I am finding the documentation on the WPML site rather difficult to follow - but I am presuming that I need to follow this section: 'Account with one website' ?

If so, please can you outline where I would find the migration code? It isn't outlined in the docs.

Thanks.

June 12, 2019 at 5:14 pm #4006341

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I might have failed to understand what you are trying to achieve. I want please to go back to the reason that you opened this ticket. You wrote:

I am trying to:
change the site domain on ams.wpml.org/panel/websites. The domain on show is for the test site domain, I want to change it to the live site domain

What is the reason that you want to change the site domain on ams.wpml.org/panel/websites?
If on your new site hidden link you go to WPML -> Settings -> 'How to translate posts and pages' and click the 'Advanced Translation Editor settings' a new tab should open with hidden link, and if you press the 'Websites' tab you get to see that you are on the panel for hidden link. Please note that if you at the same time on the same browser also logged in to your old site hidden link you might get the problem that you are getting. So in this case, please log out from the other site or keep it open on a private tab or another browser.

The documentation that I've referred you to is about transferring machine translation quota from one site to another.
Is this what you are trying to do?
Have you purchased a package for machine translation?

Regards,
Itamar.

June 12, 2019 at 5:52 pm #4006681

richardT-24

Hello - Sorry if I haven't made myself clear. I'll try again...

Both sites are actually exactly the same physical site, on the same server. 'rtdweb.co.uk/client-sites/thewesternfrontway' was the temporary domain I was using during build, and then I pointed the live domain 'thewesternfrontway.com' at that same site. So they are one and the same thing - there are not 2 sites.

There is now a holding page on 'hidden link' but that is a completely different thing - just a static html file.

While I am on 'thewesternfrontway.com' and I go to WPML -> Settings -> 'How to translate posts and pages' and click the 'Advanced Translation Editor settings' - I do go to hidden link, but then when I press the 'Websites' tab, the domain I see is hidden link. Please see screen grab attached.

I hope this makes things more clear?

Thanks,
Rich.

June 12, 2019 at 5:54 pm #4006713

richardT-24

PS - Yes, I have purchased additional an machine translation package, on top of the Multilingual CMS version - hopefully you can see that from my account details ?

Thanks.

June 12, 2019 at 7:28 pm #4007361

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for further explaining the issue.

Have you registered the new domain of your site on your account on our site here?
https://wpml.org/account/sites/
If you have not done this please do it and then insert the new key to the site.
Please see our documentation here.
https://wpml.org/faq/install-wpml/
Does this help to solve the problem?

Regards,
Itamar.

June 12, 2019 at 8:33 pm #4007577

richardT-24

Hi - No - I already did that - see grab attached. I added the relevant key from wpml.org/account/sites/ back into my site, but nothing seemed to change when I did so

I didn't want to delete 'rtdweb.co.uk/client-sites/thewesternfrontway' from there in case it trashed something on my site or the translation - In all honesty, I am a bit scared of changing WPML things now due to that amount of bugs it has caused and seemingly unrelated configurations it has changed on my site.

Thanks,
Rich.

June 13, 2019 at 7:02 am #4009739

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich.

I'm not sure whether you have checked this issue on another browser or cleared your browser's cache. If not, please try that. And also please re-save the permalinks of your site in Settings -> Permalinks. But if the problem persists, please share with me the access to your website so I can check things.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

June 13, 2019 at 9:20 pm #4016963

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich and thanks for following my suggestions.

I can see the issue on your website's panel. I'm currently consulting our second tier supporters about this issue. I'll reply here when I have more information.

Thank you for your patience.
Itamar.

June 17, 2019 at 10:28 am #4034413

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich, and thank you for your patience.

Our ATE developer has checked this issue, and here is what he explains about it.
The site that is registered on ams.wpml.org/panel/websites is a record from the first time that ATE is registered (when it was hidden link), and it is not touched after that. It is purely cosmetic and has no use in the functionality of the system.

Nevertheless, for your convenience out developer has changed the site's URL on our ATE server and now it is the correct one. Please see the attached screenshot.

Could you please confirm that this issue is solved now?

Thanks,
Itamar.

The topic ‘[Closed] I need to change the site domain on the ams wpml org/panel/websites page’ is closed to new replies.