Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 2 voices.

Last updated by Bobby 4 months ago.

Assigned support staff: Bobby.

Author Posts
April 3, 2020 at 8:28 pm #5835513

nickV-23

i did send you the information right?

April 3, 2020 at 10:41 pm #5835809

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

1. Go to Translation Management->Select your Portfolio Items and send them for translation
2. Go to your translation basket and then send them to translation from the basket
3. Afterwards go to Transaltion Tools->Bulk Automatic Translation select them and send them to automatic translation

April 4, 2020 at 9:44 am #5837605

nickV-23

Done this but I did something wrong so I deleted all the franse translations and know I want it to do it again but it doesn't work..... maybe because it thinks it has already done these but I deleted it what can I do?

April 4, 2020 at 10:22 am #5837755

nickV-23

Also, it's not showing everything in the category.

April 6, 2020 at 4:58 pm #5850987

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Were you able to re-send your portfolios for translation?

You should be able to select them and resend them for translation if needed or manually translate the ones you need to change.

Additionally, I can see that most of the categories are showing as expected here
hidden link
hidden link
hidden link

However on the page hidden link

It seems that what is causing the issue is the following setting "Sorteer Op"

1. Go to page hidden link
2. Edit the page using the WP Bakery page builder
3. Edit the masonry grid->Data Settings->Sorteer Op->Meta Value with the meta key "Year".
4. Once you switch it to "Datum" then all the category portfolio items show.

This is most likely happening because "Jar" has maybe not been translated for all portfolio items?

Notice that now I changed it to "Datum" they are showing as expected.

April 6, 2020 at 5:37 pm #5851121

nickV-23

Oke so question 1: i did it al over again but it does not appear in the bulk translation.

question 2: how is that possible? that it works on some post but not every post? the plugin even tells me what the year was in the other post. See image. why doesn't he put it there automatically?

April 6, 2020 at 6:19 pm #5851397

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

1. Which portfolio items would you like to re translate? I would like to give it a try in the backend

2. Within your system fields the ACF field for "year" was set to "do not translate" by default. I have switched it over to "copy".

April 6, 2020 at 7:46 pm #5851731

nickV-23

1. for all the portfolio items but they need to be translated again to France.

2. that's bad 🙁 is it possible to reset all my translations from the portfolio and get my translation words back and do it again?

April 6, 2020 at 11:51 pm #5852443

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I don't believe this is possible at the moment to cancel the made translations and get the words back.

But the Advanced translation editor uses translation memory therefore already made translations will not require you to re-translate them.

Meaning that you can go to portfolio items and delete your current translations under the French language, then re-translate them and the automatic translations should be there.

[I do recommend testing that on your site with just one portfolio item first before deleting all 🙂 ]

However, may I ask why would you like to re-translate the portfolio items again to French?

Is there something wrong with the translation? The translation will be the same since it's translated by automatically by the Advanced Translation Editor

April 7, 2020 at 8:12 am #5854679

nickV-23

Hi i have already deleted all the french translations. It was because i forgot to make the catorgorys so they where not put in a catogory and it would take me a lot of time to do this my self. so i deleted it and want to do it again but they do not show up in the bulk editor.

April 7, 2020 at 7:03 pm #5860531

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

When I visit your site I can see the portfolio items translated with 341 in English and 341 in French and Dutch.

Also, all categories are translated and added.

were you able to resolve the issue?

April 8, 2020 at 8:15 pm #5869809

nickV-23

That's strange because I deleted them. but it seems oke.

How can I fix the "Year" metadata translated because it's all filtered from new to old?

Btw thank you for you patient and fast response! 🙂

April 8, 2020 at 10:28 pm #5870077

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Of course !

What would you like the "Year" Metadata to be? At the moment it is set to "Copy" so it will be copied from the default language to the translations as is

April 10, 2020 at 11:05 am #5883279

nickV-23

Every portfolio item has a year. As you can see in screenshot_22. this screenshot was made from a portfolio item in dutch.

but for some reason, if I go to the translated version its empty as you can see in screenshot_23

wpml translated some of the years but not all of them. as you can see that was empty and wpml suggest "Field's value in original language: 1949".

So I don't want to put the Year value my self, I want wpml to just copy the year from dutch to English and french.

Note: it did copy the year to some translated portfolio items but not all of them. And

April 10, 2020 at 4:54 pm #5885323

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the explanation, I will update you with my results shortly