This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by armandP-2 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
April 30, 2019 at 10:02 am #3710231

armandP-2

I need to translate one button from a plugin and I can't

Is there any documentation that you are following? no

hidden link (Leer Más - botton)

April 30, 2019 at 10:28 am #3710359

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 30, 2019 at 2:47 pm #3712485

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and enabled ‘Read More’ field translation by selecting rm_text checkbox from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and hit apply button.

And added it’s translation from WPML >> String translation as you can see in the attached screenshot.

Now it showing correct translation in each language.

Thank you

May 3, 2019 at 7:20 am #3731439

armandP-2

Hi, thanks for your help, and sorry to answer you some days later.
It is perfect, but the same button, when you click on it, it shows you more content, and the button, changes its name to "Ocultar", in english, I would like to put the name "Hide", and it shows me the option to change in different languages less in English.

I actived Rl_text option on the first picture you sent me to do this, but I can not see english language to change it.

Thanks a lot for your time.

Regards

May 5, 2019 at 8:52 am #3742129

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and searched the required string from WPML >> String Translation and changed the string default language to other language by selecting required string checkbox and selected new language from ‘Change the language of selected strings’ dropdown as you can see in the attached screenshot.

And now it showing correct text in each language.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Thank you

May 6, 2019 at 7:55 am #3745625

armandP-2

My issue is resolved now. Thank you!