This thread is resolved. Here is a description of the problem and solution.

The problem: Unable to translate strings, the translation was missing from the .mo/.po file.

The solution: Go to WPML >> Theme and plugin localization and select "Translate by WPML". After that scroll down and find the plugin WooCommerce and select it. Scroll down to the bottom of the page and press the button "Scan the selected plugin for strings". After the scan completes you can go to WPML >> String translation and find and translate the strings. More information can be found in our documentation here: http://wpml.org/documentation/getting-started-guide/string-translation/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.20 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 2 voices.

Last updated by George Botsev 5 years, 8 months ago.

Assigned support staff: George Botsev.

Author Posts
October 27, 2014 at 11:58 am #500008

eminiA

I am trying to: translate the store pages to three languages German,French and Albanian. The German and French are translated automatically I think but I can't translate in albanian. Momentally at Albanian pages I the woocommerce related functions are all in english.
At first my default language was set to Albanian but after some topics I read on the internet they suggested to start from the English ones as Default but still the same issue.

The shop url is: hidden link
At the below screenshots I captured the display I'm getting at Woocommerce multilingual and Pages page. At Woocommerce multilingual it says that are missing translations for Albanian but when I press Create missing translations the Store pages are created from scratch but they are still in English

October 27, 2014 at 12:43 pm #500057

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello and thank you for contacting us.

You have to first create the missing page - as instructed in WooCommerce Multilingual.
Next you have to go to WPML >> String Translation and search for the strings that are visible in the page and translate them to the other language that you have.

If you want to do it the easy way - you could use woocommerce language pack for your languages, by going here: hidden link and downloading the appropriate files and extracting them and uploading them to /wp-content/languages/plugins/

You have to place the .mo and .po file directly there, not in a subfolder.

October 27, 2014 at 1:07 pm #500086

eminiA

I have already uploaded them to /languages/plugins

October 27, 2014 at 1:13 pm #500095

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Have you enabled "Translate by WPML" in WPML >> Theme and plugin localization?

October 27, 2014 at 1:32 pm #500122

eminiA

Yes I enabled it now. From add missing page translation it adds those two pages Cart and My Account but still they are in English.

Here is the page: hidden link

October 27, 2014 at 1:38 pm #500128

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

This are pages that you have to edit and replace the name with the appropriate translation.
Go to Pages, switch the language to Albanian and find the page that need to be adjusted and change its name like any other page in WordPress.
This would fix your problem.

October 27, 2014 at 1:48 pm #500142

eminiA

I already translated the names but inside the content its the shortcode shown
[woocommerce_cart]

From the pages menu like in the attachment screenshot I can change the name and slug only

October 27, 2014 at 1:55 pm #500152

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

The shortcode content you have to translate by using string translation module in WPML >> String translation and search for the text that you can see in English.

October 27, 2014 at 2:20 pm #500185

eminiA

There the string I need to translate aren't there. I installed PO Edit and when I oppened woocommerce-sq.po they are all empty the translation string column. I translated some of them and Saved the file from PO Edit and re-upload the .po and .mo file but no changes

October 27, 2014 at 3:10 pm #500239

eminiA

Any help please I'm still stuck here.. 🙁 I wanted to solve this problem and after that I want to add the other content Like the New products and categories

October 27, 2014 at 3:16 pm #500246

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I need to request temporary access (wp-admin and FTP) to your site – preferably to a test site where the problem has been replicated if possible – in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

October 27, 2014 at 3:54 pm #500280

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I cannot see a problem why not to translate a specific page or string.
Please provide screenshots for the exact places that you have difficulties about.

October 27, 2014 at 5:18 pm #500355

eminiA

OK These string was not here when I asked for.. can you tell me please how did you add this

Select strings within context: plugin_woocommerce

PS: The other languages like German and French seems to be fine automatically, the problem was to Albanian languange only but from Strings seems it can be solved.

Thank you for the support and please tell me how to add this contexts do I need to scan them from somewhere? I need to know what have you done to show this so I know for later don't gonna disturb you .. 🙂

PPS: Don't close this thread without answering this question 😛

October 28, 2014 at 7:14 am #500569

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

This is not a secret. Of course that I will tell you.
You have enabled "Translate by WPML", but after that you have to scroll down to the plugin section, and select the plugin WooCommerce. Place a check infront in the check-box and then scroll to the bottom of the page - there is a button - scan plugin for strings. After a while, this added the context of the plugin to your strings.
I guess that in the .mo and .po there is a partial translation for Albanian language. That is why you have to use String Translation.