This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bruno 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 11, 2019 at 7:18 pm #4192829

ranaC

I am trying to:
the domain was set long time ago for the english version...all was working great
until last week its not working anymore...it was giving not secure (i purchased a ssl for the gopeocleaning.com but the issue still not fixed)

please its very urgent
Link to a page where the issue can be seen:
hidden link
I expected to see:

Instead, I got:

July 11, 2019 at 10:38 pm #4193385

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. It looks like the domain was not configured correctly.

1. It looks like https is not working properly. This is not related to WPML.

2. When I access the link you posted above, it looks like the page displayed is from your host. I'll attach an image for you to see.

The error message that is being displayed is as if the domain is configured to be a "primary" domain and not an alias, as it should be.

---

I should suggest that you contact your host and ask them to set up HTTPS and add that domain as an alias and not as a "primary domain". Once you follow this step, when you access the link you posted above, your site should open properly.

Thank you.

July 11, 2019 at 11:44 pm #4193491

ranaC

please have a look, the domain is being added as (addon domain)
and we did installed on it SSL...as i followed ur tutorial (https://wpml.org/2016/04/use-wpml-different-domains-per-language/) and set the root folder...
i did contacted the host seens its a wpml error not hosting because the website was set since 2 years and never had problem suddenly this happened .. i updated the plugin but still.

July 12, 2019 at 12:01 am #4193559

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This does not seem to be an error with WPML simply because WPML does not configure the domains. What WPML does is, after the domains are configured, the redirection is done by WPML - according to the domain the language is displayed. That is, what WPML does is this "bridge" between domain and content.

Note in the screenshot I posted above. The HTTPS error is because SSL was not configured correctly. This is not even managed by WPML. This is exclusively a configuration of your domain/host.

Also, as I explained above, when the domain is set up correctly, when typing the domain, the site should be open, even in the default language. While the site is not open while accessing the domain, the problem is not WPML, but the configuration of the domain of your site.

In the screenshot that you posted above, it looks like you have set up a new domain, rather than setting up an alias. This may be happening just because SSL was not configured correctly. I'll attach an image of the screen that appears when I access your website.

My recommendations are:

- Please double-check SSL for the domain to be configured correctly;
- Make sure that the domain was configured as an alias and not as a primary domain. Looking at the screenshot that you posted, it looks like the domain was not configured as Alias. That's really important.

If you have any questions at any of the points above, the best option is to contact your host. They should be able to help you configure both SSL and domain as "Alias".

If everything is set up correctly, then it is necessary to wait a few hours to propagate DNS and see if the domain will be displayed correctly.

Just be sure that the properly configured domain (as alias), your site will be displayed, even in the default language, but the pages should open, that is, if the pages do not open, it is because the domain was not configured correctly.

Thank you.

July 12, 2019 at 12:48 am #4193851

ranaC

okay then why wpml is obliging me to put SSL for the other domain...lets say i have ssl on the french version ...(i did cercle on the screenshot) why i can't put a regular domain name for english ? why i don't have the option between http or https for the english?

as the host provider explained to be for the ssl to work it should me an addon domain and not pointing to the same root folder in order for the ssl to work.
by the time an Alias it points to the same root folder that's why it's giving this error.
so i need to set the domain to non https (simple http domain ) but wpml doesn't give me the option.

July 12, 2019 at 9:23 pm #4201671

ranaC

please its urgent!!

July 13, 2019 at 1:37 am #4201949

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

If you use https for the default domain, you will need to use https for the secondary domains as well. That is, by configuring HTTPS in the default domain, you will need to configure it in the secondary languages as well.

At this moment it is not possible to only use https in only one domain. The WPML shows this precisely because it does not allow you to change the HTTP in the URL to the domains.

About your screenshots, in the first screenshot, you posted the domain on the "Addon Domains" page. In your second screenshot, you posted the "Aliases" pages.

Are you keeping your domain only on the Aliases page? Or is the domain still inserted in the "Addon Domains" page as well? If you are on the "Addon Domains" page, you may need to remove the link from this page and keep it only on the "Aliases" page.

Also, when I access your site I still see the SSL (HTTPS) error.

Thank you.

The topic ‘[Closed] i set another domain for the english version suddenly it stopped working’ is closed to new replies.