This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Diego Pereira 11 months, 4 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 17, 2018 at 2:19 pm

guillermoR-9

Hi im trying to translate a ecommerce website . I did the mayor translation but when i go to test it it doesn't work. Once i click to a link in the sidebar(woocommerce pages links) it takes me to the home page ( login) instead of the page that i click. i.e. Orders page

October 18, 2018 at 3:15 pm #2828466

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @guillermor-9, welcome to the WPML support Forum!

I tried to access the website, but i'm getting a error: "DNS Update Required"

Usually this redirect happens when there is no published translation for the page. Please check if the page is already translated to that language, and if the translation is published. For this, go to the translation editor and check if the status is "100% completed".

If the issue persist, please send us the link of the page with the broken link. We will take a look.

All the best,
Diego

October 18, 2018 at 3:46 pm #2828592

guillermoR-9

Hi Diego,

Thank for the reply. I paste the wrong url this is the correct: hidden link

The pages are published and it still the problem.

Please verify again.

Kind Regards

- Guillermo

October 19, 2018 at 1:06 pm #2832153

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Guillermo,

Thanks, the credentials worked. But on what page is the sidebar located with the brokens links? I searched the website but did not find it, and all the links I tested worked normally. Could you describe the steps to reproduce the issue?

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

PHP Version
Upgrade from PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Regards,
Diego

October 19, 2018 at 1:56 pm #2832279

guillermoR-9

Hello Diego,

The steps that i take to get the error are:

1) Press the Ordering menu item.

2) Then you will see the e commerce page and whenever i click on of the link in the left sidebar it takes me bach to the login page.

I will fix toda the PHP problems.

October 20, 2018 at 2:51 pm #2834309

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It seems to me that your menu is generating links with the http:// protocol (not https:// -see screenshot), this is causing a redirection to the home.

You can check these links:
- hidden link (it will work)
- hidden link (it will redirect to home)

Where is this menu generated? is it possible to switch to the https: // protocol?

Kind regards,
Diego