This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by rogerioM-3 5 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
April 25, 2019 at 2:10 am #3677853

rogerioM-3

I am trying to: translate a page

Link to a page where the issue can be seen:hidden link

I expected to see: a 'FRENCH' menu on top right side

Instead, I got:NOTHING

April 25, 2019 at 7:38 am #3679585

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please make sure you have translated page completely and also make sure you have unchecked the box ‘Current language’ to show only 1 opposite language as you can see in attached screenshot.

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 25, 2019 at 10:39 am #3681261

rogerioM-3

Hi Norman

I cannot uncheck the option "currente page" as you can see on attached file.
I did a full backup and the page is 100% translated.

Thanks

April 25, 2019 at 10:44 am #3681297

rogerioM-3

I created a new user for you

[credentials_removed]

April 25, 2019 at 11:20 am #3681643

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have removed disabled attribute from ‘Current language’ checkbox using Firebug and then I am able to uncheck it. After that it showing opposite language correctly as you can see in attached screenshot.

Please note, I edited your reply because you had posted sensitive information in a public forum.

Thank you

April 28, 2019 at 1:06 am #3696577

rogerioM-3

Hi Norman,
I still cannot have a french version of my page.

As you can see on <image01> file, this page is still marked to be translated.
BUT, as you can see on <image02> translation is still completed at 100%

On <image 03> I cannot see the option <FRENCH> on English version.

Let me know if you need any further information

Thanks
Rogerio

April 29, 2019 at 8:51 am #3701247

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed below steps in order to fix this page issue:

1. I have added below code in wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. I went to WPML >> Support >> Troubleshooting page and pressed below buttons:
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix post type assignment for translations

3. Then duplicated ‘About Start Projecting Now’ page and issue is gone.

Could you please check and confirm?

Thank you for your cooperation and patience

April 29, 2019 at 1:04 pm #3703535

rogerioM-3

My issue is resolved now. Thank you!