This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by csabaD 1 month, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
September 1, 2019 at 11:29 pm #4493405

csabaD

I am trying to: I translated widget titles in string translation, but there is an issue.

Link to a page where the issue can be seen: for example: hidden link, hidden link. Widget titles are in only hungarian in swedish language too.

I expected to see:My front page widget titles are in hungarian (default language) and not in other language (for example swedish), when ?lang=sv is active.

Instead, I got:Other widget in my sidebar, with string translation is ok, there is no problem, but my front page isn't good.

September 2, 2019 at 7:56 am #4495095

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 2, 2019 at 12:27 pm #4496965

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have tried to enable ‘title’ element from WPML >> String Translations -> (at the bottom of page) Translate texts in admin screens », -> Open ‘widget_widget_videos_block -> 4’ tree view but it is not saving when I click on the Apply button.

- To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set these variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

After increasing max_input_vars value (screenshot attached) please follow the above steps and hit apply button. Then please go to String Translation and you will see newly enabled values at the top of the page and ready for translation, add the translation for that string and check Translation is complete checkbox and press the Save button.

To check the minimum MaxInputVars value required to save the page, please follow this doc:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/#resolving-issues-with-maxinputvars-value

- For now, I have fixed this issue by using our XML method and added the following XML code:

<wpml-config>
    <admin-texts>
        <key name="widget_widget_videos_block">
            <key name="*">
                <key name="title" /></key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now string showing correct translation at frontend.

Thank you

September 2, 2019 at 1:42 pm #4497449

csabaD

My issue is resolved now. Thank you! It was nice!