This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bruno Kos 5 months, 4 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 16, 2019 at 6:56 am #3618567

susanV-3

I expected to see:
hidden link

Instead, I got:
hidden link

April 16, 2019 at 7:40 am #3619085

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

When I visit hidden link and switch language, it takes me to hidden link. See image - it seems to be translated (not all content has been translated from what I see, but the translation works).

Regards,
Bruno Kos

April 16, 2019 at 8:10 am #3619551

susanV-3

It needs to look like the dutch one. I am adjusting it in wordpress but it will not save i guess? You can see the changes i made in the picture (english-back). When i save it, it doesn't show on the live homepage.

April 16, 2019 at 10:55 am #3621151

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Based on this image - it is both the same page actually.
hidden link
hidden link

What happens when you try editing this page:
hidden link

What content do you see?

Something has mixed here and I can't yet understand what, because what's on your image shows the content from the home page.

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

April 17, 2019 at 2:57 pm #3632157

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It seems like that something is always reverting the content, no matter what we try (I even created a new translation, to no avail, the same issue happens). It may be something related to the theme, but I am not sure.

I've tried with a new page:
hidden link
hidden link

I was able to save both content and changes remained. Can you try translating that English version and then setting is as home page once you are done?
- hidden link
-- Een statische pagina (hieronder kiezen) -> Set the English page from above

Let me know if this workaround works for you.

Regards,
Bruno Kos