Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Vincenzo 2 years, 6 months ago.

Assigned support staff: Vincenzo.

Author Posts
July 29, 2017 at 12:19 pm #1330250

willem-heinC

I am trying to: I have site in 2 language EN/BR. The shop page is fine in EN. but when switch language from shop page. the menu is converted ok (Shop should be Loja). but i did not get products.

Link to my site: hidden link

I expected to see: Products needs to see on this page

Instead, I got: I got blank page.

July 29, 2017 at 1:12 pm #1330267

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

It seems like there is some issue with the shop page and with the permalinks.

Can you please try the following steps?

1. Fix the permalinks.
- Go to Settings -> Permalinks
- Set the Product permalinks to "Custom base"
- Insert the /product/ value in that field
- Verify that the flag under the field is the English one.
- Press the "Save changes" button

2. Shop page issue.
- Please check that there are no pages in the Trash.
- Go to Pages -> All Pages -> Trash
- Press the "Empty Trash" button

Please let me know if this solves the issue or if you need further details.

Thank you

July 29, 2017 at 2:09 pm #1330278

willem-heinC

Hi Support,
Sorry we have the issues after we did above steps. There where no pages in the trash. Perhaps you can take a look in the backend? How can I send login safe to you ?

Kind regards,
Willem-Hein

July 29, 2017 at 2:11 pm #1330280

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

can you please give me more details about the issue?

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

July 29, 2017 at 3:28 pm #1330305

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

from what I can see the issue is caused by the fact that WPML media is disabled.

WPML Media is needed to activate WooCommerce Multilingual.

Can you please activate WPML Media from the plugins page and tell me if the issue is resolved?

Thank you