Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Andreas W. 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
October 13, 2019 at 7:38 pm #4745757

viktorB-10

I am trying to: get the newly uploaded images to be seen in the ATE editor

Link to a page where the issue can be seen:hidden link

I expected to see: some newly uploaded images in the ATE editor on the left (english) side

Instead, I got: the previous filenames, alt-tags and description. Not updated to the fresh ones, thus i see no point in translating them.

Something stuck somewhere in the database / string translation / shortcodes? This images are inserted via Flatsome theme's image or gallery element (shortcode).
Cheers,
Wiktor

October 14, 2019 at 11:04 pm #4753083

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML SUpport Forum.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

PHP MemoryLimit 512M
WP Memory Limit 128M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/

Further, update WPML and its add-ons to the latest version and let us know if the issue persists. (Plugins -> Add new -> Commercial -> Search for Updates)
Before doing it, please create a reliable backup of your site.

Kind regards
Andreas

October 25, 2019 at 10:36 am #4826093

viktorB-10

Hey Andreas,

I've increased the memory as you advised. I re-tried to edit the post, yet got no improvement. Still the older image filenames displayed on the left side in ATE.

Meanwhile, text strings are ABLE to get updated if i change something in them, ATE reflects it properly.

Any further idea?
Thank you,
Viktor

October 28, 2019 at 2:06 pm #4840525

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Did you also update to the latest version WPML Multilingual CMS 4.3.1, as so for all other plugins?

If this did not solve the issue I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better for a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

October 29, 2019 at 5:20 am #4843705

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for providing access to the staging.

Do you recall if it worked while using the WPML Classic Translation Editor?

It seems to me that this might be a compatibility issue between WPML/ATE and Flatsome/UX Theme.
I tried to push the image attributes applying a custom XML config in WPML -> Settings -> Custom XML Config, but without success. The issue persists, even if I disable any plugin not related to WPML.

In order to test the theme and its page builder please install the latest version 3.9.0 on the following test site and leave me a short notification once the theme is installed.

One-Click Login: hidden link

Please also leave the staging available in the meantime, if possible.

Kind regards
Andreas

October 29, 2019 at 9:02 am #4845003

viktorB-10

Hey ANdreas,

FLatsome 3.9 is uploaded now. 😉
I can't recall properly whether it worked with classic editor. A rather would say no, but not sure yet. Can you test that too or shall i?
Best wishes,
Wiktor

October 30, 2019 at 4:25 am #4852497

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have been investigating the issue on a new install:

A post was created and two images been added.

The first image was added as a WP Media element (using the plugin Classic Editor).

In this case, the image attributes "alt" and "caption" do show up on both WPML Translation Editors.
Edits on the Media Gallery were not reflecting the changes in real-time on the WP Editor.
It was necessary to delete and add the image again on the WordPress Page Editor in order to visualize the changes in the WordPress Post Editor. This behavior is the WordPress default and not caused by WPML.

Gutenberg Image Blocks behave differently. Here we are able to edit the image meta inside of the Gutenberg Block Options and from there WPML can gather the information into ATE bz using the following Custom XML Config inside of the WPML Settings:

<gutenberg-blocks>
    <gutenberg-block type="core/image" translate="1">
        <xpath>//figure/figcaption</xpath>
        <xpath>//figure/img/@alt</xpath>
    </gutenberg-block>
</gutenberg-blocks>

Meta edits have been updated on ATE on my test right after editing the Block settings and

The second image was added as UX Builder Image Element:

Here it behaved differently when making edits on the Media Gallery in the default language, as those edits were displayed in real-time on Front-End. Anyhow this did not work out for the translated page.

When trying to translate the post with ATE the UX Builder Image Element does not provide any information about the image, neither the "alt" and "caption" attributes are displayed on ATE or CTE.
Trying to gather those attributes with a custom XML config by trying to call the UX Builder Shortcode attributes failed on my test.
I received the same results here using Gutenberg or the Classic Editor plugin. The UX Builder Image elements do update the image meta edited on the Media Gallery on default language without the need to replace the image, but it does not work for the translated page.
The issue has been escalated to our compatibility team and I will let you know once I received feedback.

Could you please clarify for me from which kind of element the issue occurs on your website? In case the image meta is coming from a Gutenberg Block please use the above-mentioned XML markup at WPML -> Settings -> Custom XML Config.

In case it is a WP Classic Image Element (Custom HTML Element), simply replace the image from the Media Gallery on the WordPress Editor page, after making any edits to the image meta on Media Gallery.

It is is a UX Builder image element make sure to verify if you see any information about those images on ATE and let me know about the outcome. On my test it did not work out at all and as mentioned the issue is now escalated internally.

Let me know about the outcome.

Kind regards
Andreas

November 1, 2019 at 8:44 pm #4873019

viktorB-10

Hello Andreas!

Thank you for your great testing efforts! It makes the picture a bit more clear to me.. It's a somewhat complex issue (to my more outsider mind), so takes time to get familiar with the working mechanisms of these systems.

Well this time i continued my testing session with a UX BUilder-constructed page, and
i verify that there are 0 meta fields pulled in from/through the UX Builders' very own banner and image elements.
My main problem with this is that i can't see how it works out SEO-wise. What i see, is that on a 2ndary language version of this page the image meta is shown to me in english still. (when i go to save image as..) . SO i assume it outputs the image meta untranslated towards the crawlers, users(?) This is my main issue.

If you manage to contact with the FLatsome team regarding this issue and get info or development, that would be an epic step-forward for me. Thank you, that your team already working on this!

Other thing is: if i get it right, in case when UX BUilder is not used: it's worth to go for Gutenberg editor from now on if i want more streamlined (dynamic?) thus unblocked flow of meta data of the media files. (as Gutenberg + Wpml communicates pretty well). I do the xml config, thanks.

I stay tuned & keep testing.
hope to hear from you soon.

Best regards,
W

November 4, 2019 at 5:43 pm #4883745

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

There is a workaround.

As you can see on the native WordPress Editor the shortcode used for each image by UX-Builder includes the image ID. You can translate this ID manually by switching the language in the top admin bar on the WordPress Post Editor.

Our Media Translation Plugin will then translate the meta. The respective IDs for each image can be found on the Media Gallery image attachment pages in the browser address bar.

Please take a look at the screenshots and let me know if you do have any questions.

Also, you may take a look at my test site, if you wish:

hidden link

User: wpml
Password: support

Kind regards
Andreas

November 11, 2019 at 7:50 pm #4927731

viktorB-10

Hello Andreas,

Yes, thank you for your great support and solution to the manual ID changing. It's a working solution, that's appreciated! However, i hope the best that this 'lack-of-feature' maybe can be easily improved by the Flatsome dev team. I also keep asking/pushing them, but appreciated if your team can 'motivate' them on this with greater impact (which is maybe the reality:)

Thank you, and should i expect some feedback on this from the side of any of the Dev teams?
Best regards,
Wiktor

November 13, 2019 at 2:54 am #4935527

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Wiktor,

I am glad to hear the workaround did the trick, but surely it is not the ideal solution, as you will need to adjust each shortcode according to the corresponding ID.

I am following up with our compatibility team and I will let you know about the outcome as soon as possible.

Thank you for your kind words and patience.

Best regards,
Andreas

November 13, 2019 at 4:57 pm #4941587

viktorB-10

Thank you Andreas!
The importance is high, because even by this way (manually replacing the img ID-s) the filenames (inside FLatsome UX elements) are not being rewritten by wpml inner mechanism as i see.

Best regards,
Wiktor

November 13, 2019 at 5:20 pm #4941775

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Our compatibility team suggested the following:

As a workaround you can instead of changing the ID in the shortcode add this just after line 34 in wp-content/themes/flatsome/inc/shortcodes/ux_image.php:

$id = apply_filters( 'wpml_object_id', $id, 'post', true );

Let me know if this solved the issue.

Kind regards
Andreas

November 14, 2019 at 6:31 pm #4949433

viktorB-10

Hey Andreas!

I put that code in, but yet i still need your help. Because..as now i inspected this in more details, i tend to think that the UX image element might doing the translation properly right out of the box. I just toggled the added extra code line on and off (in /flatsome/inc/shortcodes/ux_image.php ) and it outputs the correct language's alt tag in both cases.

HOwever.. i can't tell the same about e.g. the banner and gallery elements. So maybe those elements are truly needing the extra code instead of the ux_image?

Pls check this with Flatsome team too. Huge thanks man!

Kind regards,
Wiktor

November 14, 2019 at 7:50 pm #4949741

viktorB-10

addendum to my recent previous reply: i further checked and as i see the ux gallery element is proper in terms of image seo as well (prints the alt tag at least).

So by now my 2 questions remains:
- is it possible to add alt tag output to ux_banner element?
- is it possible to output the rewritten filename as well, just like in the case of Products?
(yet Ux elements doesn't output the translated filename.)

Thank you!
W

The topic ‘[Closed] I updated/changed text and images in a post and wpml ATE cant see the new files.’ is closed to new replies.