This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 8.63 hours from now. Thank you for your understanding.

This topic contains 22 replies, has 5 voices.

Last updated by Richard 4 years ago.

Assigned support staff: Mohammed.

Author Posts
October 10, 2015 at 6:44 am #721990

Richard

I am trying to:

Upgrade WPML to latest release

URL of (my) website where problem appears:

hidden link

I expected to see:

Functioning WPML

Instead, I got:

WPML disabled due to corrupted settings.

Please help.

English is the default language
Chinese Traditional
Chinese Simplified

==================================================
WPML Multilingual CMS 3.1.8.2 => Installed/Active
WPML CMS Nav Version n/a => Not installed/Not Active
WPML String Translation Version n/a => Not installed/Not Active
WPML Sticky Links Version n/a => Not installed/Not Active
WPML Translation Management Version n/a => Not installed/Not Active
WPML Translation Analytics Version n/a => Not installed/Not Active
WPML XLIFF Version n/a => Not installed/Not Active
WPML Media Version n/a => Not installed/Not Active
WooCommerce Multilingual Version n/a => Not installed/Not Active
JigoShop Multilingual Version n/a => Not installed/Not Active
Gravity Forms Multilingual Version n/a => Not installed/Not Active
CRED Frontend Translation Version n/a => Not installed/Not Active
Installer Version n/a => Not installed/Not Active
--------------------------------------------------
icl_translations count: 2015467
setup_complete: false
setup_complete missing: true
default_language: ""
default_language_missing: true

active_languages:
Array
(
[0] => stdClass Object
(
[id] => 1
[code] => en
[english_name] => English
[major] => 1
[active] => 1
[default_locale] =>
[encode_url] => 0
[tag] =>
)

[1] => stdClass Object
(
[id] => 61
[code] => zh-hans
[english_name] => Chinese (Simplified)
[major] => 1
[active] => 1
[default_locale] =>
[encode_url] => 0
[tag] =>
)

[2] => stdClass Object
(
[id] => 63
[code] => zh-hant
[english_name] => Chinese (Traditional)
[major] => 1
[active] => 1
[default_locale] =>
[encode_url] => 0
[tag] =>
)

)

icl_sitepress_settings (serialized):
a:45:{s:25:"icl_capabilities_verified";b:1;s:21:"interview_translators";i:1;s:34:"existing_content_language_verified";i:0;s:25:"language_negotiation_type";i:3;s:23:"theme_localization_type";i:1;s:14:"icl_lso_header";i:0;s:18:"icl_lso_link_empty";i:0;s:13:"icl_lso_flags";i:0;s:19:"icl_lso_native_lang";i:1;s:20:"icl_lso_display_lang";i:1;s:18:"sync_page_ordering";i:1;s:16:"sync_page_parent";i:1;s:18:"sync_page_template";i:1;s:16:"sync_ping_status";i:1;s:19:"sync_comment_status";i:1;s:16:"sync_sticky_flag";i:1;s:17:"sync_private_flag";i:1;s:16:"sync_post_format";i:1;s:11:"sync_delete";i:0;s:15:"sync_delete_tax";i:0;s:20:"sync_post_taxonomies";i:1;s:14:"sync_post_date";i:0;s:21:"sync_taxonomy_parents";i:0;s:25:"translation_pickup_method";i:0;s:15:"notify_complete";i:1;s:26:"translated_document_status";i:1;s:17:"remote_management";i:0;s:15:"auto_adjust_ids";i:1;s:11:"alert_delay";i:0;s:12:"promote_wpml";i:0;s:23:"troubleshooting_options";a:1:{s:18:"http_communication";i:1;}s:18:"automatic_redirect";i:0;s:17:"remember_language";i:24;s:17:"icl_lang_sel_type";s:8:"dropdown";s:18:"icl_lang_sel_stype";s:7:"classic";s:24:"icl_lang_sel_orientation";s:8:"vertical";s:28:"icl_lang_sel_copy_parameters";s:0:"";s:21:"icl_widget_title_show";i:1;s:28:"translated_document_page_url";s:13:"auto-generate";s:28:"sync_comments_on_duplicates ";i:0;s:3:"seo";a:2:{s:10:"head_langs";i:1;s:27:"canonicalization_duplicates";i:1;}s:22:"posts_slug_translation";a:1:{s:2:"on";i:0;}s:15:"languages_order";s:0:"";s:4:"urls";a:5:{s:30:"directory_for_default_language";i:0;s:12:"show_on_root";s:0:"";s:19:"root_html_file_path";s:0:"";s:9:"root_page";i:0;s:23:"hide_language_switchers";i:1;}s:22:"admin_default_language";s:9:"_default_";}

icl_sitepress_settings (unserialized):
Array
(
[icl_capabilities_verified] => 1
[interview_translators] => 1
[existing_content_language_verified] => 0
[language_negotiation_type] => 3
[theme_localization_type] => 1
[icl_lso_header] => 0
[icl_lso_link_empty] => 0
[icl_lso_flags] => 0
[icl_lso_native_lang] => 1
[icl_lso_display_lang] => 1
[sync_page_ordering] => 1
[sync_page_parent] => 1
[sync_page_template] => 1
[sync_ping_status] => 1
[sync_comment_status] => 1
[sync_sticky_flag] => 1
[sync_private_flag] => 1
[sync_post_format] => 1
[sync_delete] => 0
[sync_delete_tax] => 0
[sync_post_taxonomies] => 1
[sync_post_date] => 0
[sync_taxonomy_parents] => 0
[translation_pickup_method] => 0
[notify_complete] => 1
[translated_document_status] => 1
[remote_management] => 0
[auto_adjust_ids] => 1
[alert_delay] => 0
[promote_wpml] => 0
[troubleshooting_options] => Array
(
[http_communication] => 1
)

[automatic_redirect] => 0
[remember_language] => 24
[icl_lang_sel_type] => dropdown
[icl_lang_sel_stype] => classic
[icl_lang_sel_orientation] => vertical
[icl_lang_sel_copy_parameters] =>
[icl_widget_title_show] => 1
[translated_document_page_url] => auto-generate
[sync_comments_on_duplicates ] => 0
[seo] => Array
(
[head_langs] => 1
[canonicalization_duplicates] => 1
)

[posts_slug_translation] => Array
(
[on] => 0
)

[languages_order] =>
[urls] => Array
(
[directory_for_default_language] => 0
[show_on_root] =>
[root_html_file_path] =>
[root_page] => 0
[hide_language_switchers] => 1
)

[admin_default_language] => _default_
)

==================================================

October 10, 2015 at 4:08 pm #722093

Richard

Any help?

If I click Reset Settings, can I just redo my settings?

Please confirm that this will NOT delete all my icl_* tables etc like the Reset function on the troubleshooting page. I can not afford to lose all that data as it is too much to redo. This is unclear to me as it says:

"Reset Settings button: this will reset WPML settings and any language translation information, allowing you to restart the wizard."

Is "language translation information" all the icl tables?

Thanks,
Rich

October 11, 2015 at 6:15 pm #722286

Richard

Does anybody know?

I don't mind redoing my settings if the Reset Settings does not delete all my data. Meaning, I just have to reconfigure WPML and everything will work again. I don't know though because to me the language is unclear on this.

Any help?

If I click Reset Settings, can I just redo my settings?

Please confirm that this will NOT delete all my icl_* tables etc like the Reset function on the troubleshooting page. I can not afford to lose all that data as it is too much to redo. This is unclear to me as it says:

"Reset Settings button: this will reset WPML settings and any language translation information, allowing you to restart the wizard."

Is "language translation information" all the icl tables?

Thanks,
Rich

October 12, 2015 at 9:16 am #722557

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello and thank you for contacting WPML support!
I will take care of your ticket.

Sorry for the delay in the answer.

To fix WPML settings without resetting translations I need to perform a small procedure.

In order to do so - could you provide me with some more details?

1) What is your default language?

2) To which other languages do you like to translate to? (target languages)

3) Could you provide us with credentials for your website? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")

Thanks in advance!

October 13, 2015 at 1:04 pm #723802

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Since Vincenzo currently has a few days off, I will replace him here in the forum.
I hope this is OK for you.

We are not allowed to publish the process to fix this issue.
It includes Code Changes in your Themes Files (unique) with should be performed by a supporter only, and only after a backup.

In order to solve this issue, I would need some more details and permissions:

1. Please confirm to have made a full Database Backup

2. OPTIONAL
Please install the Plugin "Adminer", or provide me another access method to your database

3. FTP NEEDED
I would need to request temporary access (WP-Admin and FTP) to your site
(I will enable a private answer so you can provide this in a secure way)

4. DONE
I would need to know the default language of your website,
and the active languages.

You perhaps didn’t manage yet to create any content in a non default language:
we need to know anyway at least one language to activate.

Thank you for your patience.

October 13, 2015 at 6:32 pm #724109

Richard

Also, I did install Adminer for you

October 14, 2015 at 1:37 pm #724808

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you,
I'm going to work on the site in 5 minutes.

I will update this ticket as soon as I finish

October 14, 2015 at 3:05 pm #724929

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sorry for the delay.

I think the problem here is that WPML has been upgraded straight from version 2.6.0 to 3.2.7.
Please correct me if this is not what happened here.

❌ Please make a full website backup before proceeding! ❌
⌥ You can use a plugin for this.
Usually, I use the free Duplicator plugin.
See: http://wordpress.org/plugins/duplicator/
It could be useful to try this in a test site before updating the production site.

To solve the problem please follow these steps:
- Restore a backup of the website that you made before upgrading to WPML 3.2.7 (if you have one)
- Delete the current WPML plugins.
- Please install and update WPML using this sequence 2.6 -> 2.9 -> 3.0 -> 3.1.7 -> 3.1.9.7 -> 3.2.7
You can find old WPML versions here:
- https://wpml.org/download/wpml-multilingual-cms/?section=changelog

October 14, 2015 at 4:01 pm #724989

Richard

I updated to the latest version of plugin when it was presented to me via the WordPress update system. The other versions never were presented that way. Updating with the none released versions was not a prerequisite.

I can go back to the a previous version as I will lose work from the days since then.

Please offer another solution.

October 14, 2015 at 4:03 pm #724992

Richard

Sorry. I can not go back to previous version as I will lose all our work since then.

Also. What did you do when on our site?

It no longer is functioning properly. Please tell me what you did via other plugins as I need to get it running properly again. Did you do anything to other plugins? Did you touch our caching plugin?

October 14, 2015 at 4:04 pm #724993

Richard

Also. I have a ocp cache which caches the php pages. So if you made any changes to any php code. That has to be reset.

Rich

October 14, 2015 at 4:13 pm #725007

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, I'm sorry, I forgot to enable the caching plugin again, I had to disable it because sometimes it interferes with the WPML setting restore procedure.

I made small PHP changes to a default theme file (twenty fourteen) to avoid any problem with the live site. I already removed that modification.

Here is another possible solution:

To further debug the problem I’d like to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:
If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

You can just filter out the cache, wp-upload, media and archive files to reduce the package size.

:: Duplicator instructions
. From WordPress plugin page, look for “Duplicator” and install it
. Once installed, you get a new main menu “Duplicator”
. Chose “Packages”
. Click on the first button you find in the toolbar on the right (“Create Package”)
. Give it a name or leave it as is
. Click on “Create Package Set”
. Wait until the package is ready
. Click on “Installer”, then on “Package”: the first one is just a php script, the second one is a zip file containing everything you need
. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to login. You may delete the new admin account once the snapshot has been built.

Once the problem is resolved I will delete the local site.

October 14, 2015 at 4:26 pm #725016

Richard

We don't use the default theme so that should have any effect. That was the only php file you changed? If the WPML settings are in a php file and then copied to the db the ocp cache would of had to be cleared.

I can not use duplicator for our site. I tried in the past for another issue with WPML and it never worked. Our site is too large and it fails.

Rich

October 14, 2015 at 4:27 pm #725017

Richard

Default theme should not of had any effect I mean.

October 14, 2015 at 4:34 pm #725019

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

That is why I use a non-active theme.

If Duplicator is not a viable option, can you please create a staging environment or a test site where the problem is replicated?