This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 5 voices.

Last updated by Richard 3 years, 12 months ago.

Assigned support staff: Mohammed.

Author Posts
October 14, 2015 at 6:31 pm #725091

Richard

Ok. I used duplicator and made a snapshot of the site, minus all the media.

I do not know how to send (or fileshare) it to you as you did not provide an email address.

Rich

October 14, 2015 at 6:43 pm #725096

Richard

Also, I don't think it's a good solution to say that I improperly updated the plugin when it was pushed out by WPML.org through WordPress.

I specifically waited until the new version of WPML was offered through the WordPress Plugin update process. I saw the previous versions of the plugin were offered as manual downloads, but I waited for the "official" release via WordPress thinking this would insulate me from any upgrade issues because all the kinks would be worked out by then.

If the plugin is not able to upgrade properly from the version I had, then it should not have proceeded to try and do the process. It should of aborted.

Rich

October 14, 2015 at 9:23 pm #725183

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sorry, I clearly didn't mean to say that it was your fault.
I was just saying what I thought the problem was and proposing a solution (the more gradual update)

I'm enabling a private answer so you can share with me the links to the Duplicator package and installer file in a safe way.

October 14, 2015 at 9:50 pm #725199

Richard

I understand.

Thanks,
Rich

October 15, 2015 at 8:58 am #725459

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thanks for your files.

I just downloaded them and I will come back to you soon.

Best Regards.

October 16, 2015 at 8:37 am #726507

Maciej

Hello,

My name is Maciej, Vincenzo is away today.
I will check the provided by you Duplicator copy and let you know as soon as I find a solution.

Kindest regards,
Maciej

October 19, 2015 at 5:09 pm #728247

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Rich,

Macej and Vencenzo are off these days and I will replace them in this ticket,We are sorry for this inconvenience.

I've downloaded a copy of your website locally and I succeeded to solve the issue by doing the following:

- Make sure that you have a database and files backup, It's supposed that everything will be OK after doing the following steps. But It always good to have a backup.

- Using a FTP program like filezilla, Open the footer.php file located directly under your active theme directory.

Add the following code just before the </body> HTML tag

<?php
global $sitepress;
 
$setup_complete = $sitepress->get_setting('setup_complete');
$default_language = $sitepress->get_setting('default_language');
 
if(!$setup_complete) {
    $sitepress->set_setting('setup_complete', 1);  
}
 
if(!$default_language) {
    $sitepress->set_setting('default_language', 'en');    // <----- MAKE SURE TO KNOW WHAT'S THE WEBSITE DEFAULT LANGUAGE BEFORE DOING SO!!!!
}
$sitepress->save_settings();
?>

- Visit your website homepage
- Edit the footer file again and remove the above code.
- Open your phpmyadmin and select your database
- Run this query

SELECT * 
FROM  `wp_options` 
WHERE  `option_name` LIKE  'icl_admin_messages'

-Change the key name of the returned result to be "icl_admin_messages_" instead of "icl_admin_messages".

Please let me know if you faced any troubles.

Thanks.

October 19, 2015 at 6:13 pm #728291

Richard

Ok. I did this. The error message is now gone.

It seems you just manually set the setup complete flag and hid the message.

Thank you,
Rich