Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: The client was trying to import translations for an existing .po file but the translations were not loading in his Theme's context

Solution: After advising client to select proper context the issue was resolved

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.64 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by amjadA 6 years, 6 months ago.

Assigned support staff: Dimitris.

Author Posts
December 28, 2014 at 4:14 pm #534462

amjadA

I am trying to: upload file ar.po for translation but nothing happened

I visited this URL: hidden link

I expected to see: All word in English translation Arabic

Instead, I got: All word English
I change file wp-config.php to define( 'WP_DEBUG_LOG', true ); but nothing happened
Please help me

print.jpg
December 29, 2014 at 8:18 am #534570

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hello,

I can't access your site as a "Under construction" page came up. Could you please provide us temporary access in your site so we can try to resolve this faster. Please post your WP-Admin and FTP access details in the fields below the comment area when you log in to leave your next reply.

Also, it would be helpful if you also provided us with a link to your .po file so we can test it directly.

Finally, please avoid making double threads for similar issues. If possible please close your other thread here: https://wpml.org/forums/topic/i-upload-file-po-but-nothing-happen/

Happy holidays 🙂

Regards,
Dimitris

December 30, 2014 at 7:24 am #535060

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi,

I have checked your details and I was able to log in. I will try to resolve this today and keep you informed.

Also, I'm closing this thread: wpml.org/forums/topic/i-upload-file-po-but-nothing-happen/
as I believe it's a duplicate.

Regards,
Dimitris

December 30, 2014 at 8:25 am #535081

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi,

I've tried to upload the .po file myself and I haven't faced any issues. I've selected the Context shown in the screenshot and the strings were loaded properly in the String Translations table.

Are you having problems with a specific context?

Regards,
Dimitris

po-context.jpg
December 30, 2014 at 12:43 pm #535240

amjadA

Thanks you

But I Have problem in View
No translator
For Example Go this link hidden link
See this Print Screen in file attached

print-screen.png
December 30, 2014 at 2:00 pm #535280

Dimitris
Supporter

Timezone: Europe/Athens (GMT+03:00)

Hi,

These strings were not translated as you haven't selected the corresponding Context.
I uploaded the .po file again, selected "theme media center" as context and the string translations were loaded properly.

You will need to upload the file multiple times and select the appropriate context each time.

Hope this helps 🙂

Regards,
Dimitris

January 14, 2015 at 8:06 am #542108

amjadA

Thank you