This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 9.64 hours from now. Thank you for your understanding.

This topic contains 34 replies, has 2 voices.

Last updated by husseinA-8 2 weeks, 1 day ago.

Assigned support staff: Bigul.

Author Posts
August 22, 2019 at 1:15 pm #4439611

husseinA-8

I am trying to: to translate dokan dashboard menu links

Link to a page where the issue can be seen: hidden link

I expected to see: every link goes to the right page

Instead, I got: back to english dashboard

this is an example:

The right url is:

hidden link

The auto generated url is:

hidden link

August 22, 2019 at 6:37 pm #4442255

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

All the URLs you have mentioned in the first is post is wrong ones, am I right? Because it is showing 404 error. Please check the attached image.

So please let me know the exact steps to reproduce the issue on your site.

Also please try the following steps and check the issue is existing or not.

1) Visit WPML>>Languages>>Language URL format
2) Choose *Different languages in directories* option
3) Save the settings
4) Visit Settings>>Permalinks
5) Resave the settings

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

August 22, 2019 at 6:55 pm #4442291

husseinA-8

Hello Bigul,

Hope you are doing great.

English url:

hidden link

it shows products

this is the auto gentrated url:

hidden link

and this is the right one:
hidden link

but it does not show products and translated page uses different color (css) on hover

thanks for your help
Best regards

August 22, 2019 at 7:21 pm #4442435

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps and make sure is there any difference in the result.

1) Visit WPML>>Languages>>Language URL format
2) Choose *Different languages in directories* option
3) Save the settings
4) Visit Settings>>Permalinks
5) Resave the settings

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

August 22, 2019 at 10:00 pm #4443069

husseinA-8

Hello Bigul,

Thanks for your help.
it's working
but this url is not working:

hidden link

Best regards

August 23, 2019 at 7:27 am #4444839

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

August 23, 2019 at 7:06 pm #4449579

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. The issue is only happening for the Order section of Dashboard pages, am I right? While showing 404 error the page is still linked to English Dashboard Order page.

So please share with me the WordPress debug.log (not WPML debug information).

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

August 23, 2019 at 8:27 pm #4449791

husseinA-8

Hello Bigul,

this is the url:
https://pastebin.com/embed_js/z78h4Ver

Best regards

August 23, 2019 at 8:38 pm #4449795

husseinA-8

Hello Bigul,
plz see this log.

https://pastebin.com/embed_js/v262yqFD

Best regards

August 25, 2019 at 11:29 am #4453971

husseinA-8

Hello Bigul,
Hope you are doing great.
any reply?
Best regards

August 26, 2019 at 8:00 am #4456587

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and Debug log information. The Debug log is not showing any warnings or errors related to WPML. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 26, 2019 at 7:47 pm #4461083

husseinA-8

Hello Bigul,
thanks for helping.
ok you can do that.
Best regards

August 27, 2019 at 12:14 pm #4466371

husseinA-8

HelloBigul,
any update?
Best regards

August 27, 2019 at 2:09 pm #4467565

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 28, 2019 at 4:38 pm #4476021

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am continuing the debugging on the issue and it is existing after the initial checks. Therefore sharing the details our team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul