This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WooCommerce Cart become empty while switching between the languages

Solution: WooCommerce Cart become empty while switching between the languages. It works fine after the following steps. Please try it after a site backup.

1) Upgrade to the latest version of WPML(4.2.8) and WooCommerce Multilingual(4.6.7) 2) Visit Settings>>Permalinks 3) Choose *Post name* option and save the settings 4) Visit WPML>>Languages>>Language URL format 5) Choose *Different languages in directories* option and save the settings 6) Visit Settings>>Permalinks and update the settings(just resave)

Relevant Documentation: https://wpml.org/forums/topic/i-use-v-4-2-7-1-woocommerce-empty-basket/page/2/#post-4539085

This topic contains 19 replies, has 3 voices.

Last updated by guentherJ 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
August 26, 2019 at 3:58 pm #4460257

guentherJ

Not able to add products to the Basket - Basket is empty

Now i have disabled all WPML Stuff and it works. But i have all Products in German and English - not fine 🙁
Is there any Solution ?
Best Regards Günther

August 27, 2019 at 9:06 am #4464079

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Does it happen with all the Products in both languages? Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

August 27, 2019 at 9:38 am #4464453

guentherJ

hy
I diabled all plugins and switched to a default template - it works. step by step i enabled the plugins, it works as long as i enable WPML. English and german Articles are not add to the Basket.I read in this forum ( i don`t remember where) there is a Beta of WPML that fix this bug, but i cannot find any place to download it.

August 27, 2019 at 6:22 pm #4469039

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. You can download the Beta version from https://wpml.org/account/downloads/ or Your Dashboard>>Plugins>>Add New>>Commercial tab by choosing *Beta* option for the Channel drop-down box. Please check the attached images for more details.

Please note, Beta version are not recommend in the live site because it is still in the testing stage.

Please share me the debug information for further details.

--
Thanks!

Bigul

August 28, 2019 at 9:49 am #4472927

guentherJ

here are the debug infos, wpml don`t work

August 28, 2019 at 6:29 pm #4476327

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please activate WooCommerce Multilingual plugin after a site backup and check the issue is existing or not.

https://wpml.org/documentation/related-projects/woocommerce-multilingual/

I have a request. Please upgrade the following configuration for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

August 29, 2019 at 4:49 pm #4482817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

August 30, 2019 at 1:49 pm #4487551

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. But the site is asking for the authentication while accessing the login page. So please share me the authentication credentials.

--
Thanks!

Bigul

August 30, 2019 at 7:17 pm #4489053

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But the authentication credentials are not working for me. Please check.

--
Thanks!

Bigul

August 31, 2019 at 4:18 am #4490147

guentherJ

Good morning

I have tried this use and password - it works with safari, chrome and firefox . Any idear what to do ?

September 2, 2019 at 11:21 am #4496517

guentherJ

hy - sorry it works from here, but i have a idea.
if you can get me a e-mail adress so you can klick on "lost Password" and create a new one that works for you

September 2, 2019 at 5:26 pm #4499401

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please check the attached image. The login page is not visible for me. Only has authentication login box and it is not working with the credentials you have shared.

--
Thanks!

Bigul

September 3, 2019 at 7:15 pm #4507055

guentherJ

Hy thank you for your help, need a view minutes...

all the files are in dropbox:
Link to the file moved here https://wpml.org/forums/topic/i-use-v-4-2-7-1-woocommerce-empty-basket/page/2/#post-4499683 for security reasons.
best regards and good luck

September 4, 2019 at 3:48 pm #4512647

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Gunther and Bigul 🙂

I moved the link to the files to this private reply:
https://wpml.org/forums/topic/i-use-v-4-2-7-1-woocommerce-empty-basket/page/2/#post-4499683

so they are not exposed.

Kind regards,

Otto

September 4, 2019 at 5:04 pm #4513087

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the backup files. I will work on it and get back to you soon. Please wait.

--
Thanks!

Bigul