This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 6 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 3, 2019 at 11:25 pm #3530793

mohamad-hamzaa

i use WPML for my woocommerce site
when website run in localhost it work perfectly
but when i upload thw website on live server, language translation is not working

April 4, 2019 at 12:15 am #3530951

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Could you please verify your settings structure at WPML -> Language -> Site URL structure. I would advise you to select different domain per language on the live site.
Then go to Settings -> Permalinks and choose a complex permalinks setting like Date & Name or a custom one. Then save the changes.

Now, unless the issue is solved please give more details about what is not translated correctly. Some screenshots and links could be helpful.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 4, 2019 at 7:23 pm #3537921

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

How did you migrate your localhost to live? Did you use any plugin or did you migrate manually?

Could you please go to WooCommerce -> WooCommerce Multilingual -> Status. (Screenshot 1)
You will see that the product permalink base is not translated yet. Please complete the task. Any URL related to your WooCommerce Store can further be translated on the Store URL tab.

Now, scroll to the bottom of thus screen and you should see the option "Troubleshooting" in the right corner. Click it and complete the synchronization of your store content.
(Screenshot 2)

Next, go to Appearance -> Menus and add the translation for your Arabic Menu. Please take not that if you refer here to pages or taxonomies that are not yet translated then they will also not be available in Arabic language.
(Screenshot 3)

Taxonomies like categories and tags can be translated at WPML -> Taxonomy translation.

At last go to WPML -> WP Menus sync and scroll to the bottom. Now click the Sync button. This will order your menus for each language.
(Screenshot 4)

Text in Footer, Header or those from the theme options can be translated with String Translation. You will find more options on the bottom of the screen by clicking on "translate texts in admin screens".
https://wpml.org/documentation/getting-started-guide/string-translation/

Let me know if you need any further assistance and please provide screenshots and links for the strings that are still needing a translation.

Kind regards
Andreas

April 6, 2019 at 4:51 pm #3549679

mohamad-hamzaa

HELLO
MY ISSUE ISN'T SOLVED , I STILL NEED YOUR HELP TO FIX THIS PROBLEM
I WAS FOLLOW YOUR STEPS BUT THE ISSUE IS NOT SOLVED YET.
ALL TRANSLATION IS NOT WORKING, WHEN I SWITCH TO ARABIC LANGUAGE, HE REDIRECT ME TO SHOP PAGE IN ARABIC AND ALL MY PAGES ON ARABIC EXCEPT HOME PAGE IS NOT WORKING ALTHOUGH THERE WAS TRANSLATION FOR HIM

AND I WAS MIGRATE MY WEBSITE WITH FILEZILLA MANULY

April 8, 2019 at 2:49 pm #3559193

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

As far I can see the English store is working correctly but there are some strings on the Arabic store that still need to get translated.

Starting with the menu I can see that you did not create a menu at Appearance -> Menus.

Please recreate your Arabic menu here and translate it to English. Afterwards you will be able to synchronize these menus at WPML -> WP Menus Sync. This will help you to keep the menus ordered.
https://wpml.org/documentation/getting-started-guide/translating-menus/

Next you will need to translate strings from Widget like those in the footer and other single strings with our String Translation Add-on. You can use the free text search to locate the strings.
https://wpml.org/documentation/getting-started-guide/string-translation/

See in the screenshots how I translated the heading "Categories" by using String Translation.

Please let me know if you have problem to locate some strings on our String Translation module. I will be glad to assist you.

Kind regards
Andreas

The topic ‘[Closed] i use WPML for my woocommerce site when website run in localhost it work perfec’ is closed to new replies.