Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by rikkertZ-2 1 year, 4 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 23, 2018 at 8:37 am #2841484


Tell us what you are trying to do? The default language of my website is Portugues, while my frontpage is in English. I want the default language of the frontpage also to be in Portugues

Is there any documentation that you are following? I have been looking into your forum and documetation

Is there a similar example that we can see?

What is the link to your site? hidden link

October 23, 2018 at 6:34 pm #2843845

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for contacting WPML Support. Regarding your question, I could notice your frontpage is properly showing content into portuguese language, although there are still english text, for example in the search fields. In this case I would recommend:

1 - Make sure you have one of the options 'Translate themes and plugins using WPML's String Translation only' checked in your WordPress Dashboard > WPML > Theme and plugin localization > Localization options.

2 - Scan your theme text to make it available for translation in your WordPress Dashboard > WPML > Theme and plugin localization > Localization > Strings in themes.

3 - In your WordPress Dashboard > WPML > String Translation click to select your theme language domain (usually the theme name) from the 'Select strings within domain'

4 - Translate all the text you still have missing translations. Don't forget to always check the option 'Translate is complete' for any translation you make, otherwise it won't appear on the frontend.


Please, let me know if it helps and if you need additional clarifications. Have a nice day.

October 26, 2018 at 7:23 am #2852133


My issue is resolved now. Thank you!