This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by salemA-3 1 month, 1 week ago.

Assigned support staff: Bruno.

Author Posts
August 28, 2019 at 3:49 pm #4475703

salemA-3

Hello,

I'm tying to connect an Arabic Post with the original English Post (Site default language is English)
Here is the post hidden link
And here is the Original English Post hidden link

Now, I know that it is through 'Connect with translations' button, but it doesn't show that in the Arabic Post, like in the image attached.

And when I try to connect it from the English Post with 'Connect with translations' the whole post doesn't show in the search.

How can I connect it to that post without creating a whole new post?

Thanks

August 28, 2019 at 4:49 pm #4476063

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

As far I can see from your screenshot you are on the arabic post page and the site default language is English.

Is it correct that the post was created in English and then translated to Arabaic?

If so, please go to the English post page and see the posts relation here.

Further, I can see that the post seems translated but the translation is still in prgress or was not saved.you are You are translating manually, using the WordPress Editor for the translation, correct?

Did you consider activating one of our WPML Translation Editor?

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Kind regards
Andreas

August 28, 2019 at 6:34 pm #4476359

salemA-3

Hello Andreas,

The English post and Arabic were created separately.

When I open English post editor, it says that I need to add a new translation or duplicate it like in the picture attached, which I don't want to, because I already have the post in Arabic.

So I tried the 'Connect with translations' link to connect it with the Arabic version, but the Arabic post doesn't show in the list for some reason, it might be because as you said, that I have started adding a translation for the Arabic and stopped.

What I really want to do is, to go to the Arabic post, and just link it to the English post, without translating, like I always do. But the problem here is the 'Gears' icon that I have attached, when it is there, I cannot find 'Connect with translations' link.

I have tried pressing the 'Gears' icon and pressed 'Resign' button that I have also attached. To make the 'Gears' icon disappear and everything go back to normal, but no luck, it takes me to 'Translations queue' for some reason, then I go back to the post, and the 'Gears' icon is still there.

How can I make the post go back to the normal state, with the 'Connect with translations' link available?

Note: The 'Translations queue' screen has everything as 'Complete', there isn't any unfinished translations.

August 28, 2019 at 7:52 pm #4476729

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 28, 2019 at 9:43 pm #4476925

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have canceled the translation job for محطة المناصير للمحروقات / ماركا from the Translation Management Translation Jobs Queue and the "in progress" symbol is not longer appearing on this content.

Anyhow, there are not coming up more than two when it comes to connect store locations.

Would you be able to try if you get the same result if you disable any additional plugins but the Store Locator Plugin and WPML? If so, I would like to try to recreate the issue on a new installation of WordPress and escalate to your compatiblity team, if needed.

In case, please install the WordPress Store Locator Plugin and any additional missing plugin in order to recreate the issue. I would be a great help if you could create a few examples, appy the respective settings and verify if you get the same issue on this new install.

One Click Login: hidden link

Further, I would be able to connect those posts on the database directly. If you could provide access to your PHPmyAdmin I would like to offer you to have a look at it.

Those posts should be located on the icl_translations table:

Manaseer Gas Station / Marka = Element ID 680
محطة المناصير للمحروقات / ماركا = Element ID 807

Here both elements will need to be assigned to the same indvidual value inside of the field "trid". Please also verify that the identical element_type is assigned to each post.

https://wpml.org/documentation/support/wpml-tables/

Let me know if you need any further assistance.

Kind regards
Andreas

August 30, 2019 at 6:00 pm #4488685

salemA-3

Hello Andreas,

I have created a replica site, for you to play around with:
hidden link

The database thingy, will solve the issue for me.

But please figure out the problem for better user experience.

Thanks

Oh, one last question, how did you cancel the translation job? I'm unable to do that, it says only for local jobs? Check the image.

August 30, 2019 at 8:40 pm #4489181

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

At the moment, Andreas is absent. I would like to take care of your ticket from now until he returns.

In order for us to better analyze your site, we should ideally install Duplicator or All in One Migration on your site so that we can test in our test environment. Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

That way we will be able to check why this Arabic page is not being displayed to connect with the English post.

On your second question, may I kindly ask you please to open a new ticket for your new question? According to our guidelines, only one issue per topic is allowed. Also, this will also help other users with similar problems find solutions when searching the forum.

Thank you.

September 9, 2019 at 7:52 pm #4540011

salemA-3

My issue is resolved now. Thank you!