This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Yvette 3 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
July 4, 2019 at 1:15 pm #4143723

carolineM-18

I want to duplicate a page to another language, but when i translate/duplicate a page it only duplicate content and style/css missing in translated page.

Below is page link which i want to duplicate to another link.
hidden link

Below is page link duplicated from above page.
hidden link

July 4, 2019 at 2:29 pm #4144433

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It may be that your styling information is not being held at the "page" level in post-meta custom fields but rather, stored as theme settings.

If this is the case, then you would have to register and translate these theme options with StringTranslation.

I can check this possibility for you if you give me access to your dashboard and provide a simple sample page that illustrates the problem.

Thanks

July 5, 2019 at 7:44 am #4148635

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I am unable to replicate the problem.

I translated the demo page you provided into zh-hant and fr using the WPML Translation Editor.

1- ZH-HANT
This version had already a translation in progress, I simply "completed and saved" the translation.

2. FR
The fr version, I first duplicated and then "translated independently". Then I "completed and saved".

In both cases, the translated page looks exactly like the original source page. I did notice that the language switcher is not working in the menu, so I activated the footer switcher to facilitate the switching.

Please open a new ticket for the language switcher issue.

July 8, 2019 at 5:53 am #4159199

carolineM-18

I translated home page to German, but when i choose "Different languages in directories" in Language URL format option in WPML Settings, and click on german flag in dropdown in footer on home page, it always shows english version and not other languages version of the page, and when i select "Language name added as a parameter", and when i click on any flag in footer, it shows 404 not found page, Please resolve it fast, it is very urgent.

July 8, 2019 at 7:16 am #4159479

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

You are receiving this error because there are/is currently no DE pages existing (see image). There are no DE pages existing because the save action is unable to complete due to mixed content error (see image).

The migration that you made to https is somehow not complete. This is not necessarily related to WPML but here are some similar tickets that might give you a hint on how to address the problem:

https://wpml.org/forums/topic/loaded-over-https-but-requested-an-insecure-stylesheet/
https://wpml.org/forums/topic/css-error-when-change-http-to-https/page/2/#post-1196979

July 8, 2019 at 7:51 am #4159637

carolineM-18

We have resolved https errors, but still we are receiving 404 not found page for other languages. please check this issue, it is very urgent for me to resolve this issue ASAP. Please take this significantly.

July 8, 2019 at 8:41 am #4160117

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Could you please install/activate the "Duplicate Post" plugin?

July 8, 2019 at 9:01 am #4160403

carolineM-18

Ok i have installed Duplicate Post plugin.

July 8, 2019 at 9:56 am #4160727

carolineM-18

I am still having same issue, please look at this and resolve it.

July 8, 2019 at 10:05 am #4160805

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It seems that the string package associated with the Home page is corrupted in some way - perhaps it is not synchronised with the current job-id or similar.

- I cloned the home page to "Home New"
- I then opened the old Home page in the Translation Editor and cut&paste the contents of the DE translation to the De version of "Home New". I did not do all of the fields - just enough to test that the translation is saving.

Here is the result:
hidden link

I would suggest that you work to complete the translation of the "Home New" and then make it the new "home page" of your site.

I believe that this is the best workaround for you at the moment.

The topic ‘[Closed] I want to duplicate a page to another language.’ is closed to new replies.