This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Marcel Elbers 11 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
October 10, 2018 at 1:01 pm #2804317

Marcel Elbers

Tell us what you are trying to do?
i am trying to translate some woocommerce customized tabs made with divi
Is there any documentation that you are following?
no
Is there a similar example that we can see?
please see the attached printscreens
What is the link to your site?
hidden link only the site is underconstruction now.

I tried to translate it in the last printscreen i uploaded but nothing is translated. Does it have to be 100% translated before you see it online?
Thanks,

October 11, 2018 at 8:02 am #2807090

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Does it have to be 100% translated before you see it online?

Yes, it has to be 100%, so could you please make the translation 100% and let me know if this helps.

Thanks

October 11, 2018 at 8:15 am #2807139

Marcel Elbers

ok but problem is only that i see so many images to translate please see here hidden link the images do also not belong to the product pages but to the blog. How to solve this?
Thanks.

October 11, 2018 at 10:27 am #2807594

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Have you added those images to the product gallery?

I think that marking all those fields one by one can take a lot of time, could you please use the solution provided here to mark all fields at once and let me know if this helps?
https://wpml.org/forums/topic/bulk-complete-translation/#post-2631921

Look forward to your reply.

Thanks

October 11, 2018 at 12:47 pm #2808174

Marcel Elbers

These images have been probably been added to the gallery. I think we have a lot of double images as we had some problems with an upgrade we had to do all blog post again.

I managed to mark all fields as you instructed. The “product page7” is now 100% translated but i don't see the translation on the frontpage it's still all in English. Also it does not say it is translated. I open the transaltion again it jumps back to only 74% translated, this happens actually always.

Am i doing the translation in the correct place?
What's the next step?

Thanks

October 12, 2018 at 5:04 am #2810805

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

When you have a lot of fields and you try to save those translations, these all fields don't get saved sometimes, this is caused by MaxInputVars, so could you please contact your hosting provider once and ask him to increase the MaxInputVars to 6000 and try it again. If it still get stuck on some percentage you will need to increase the MaxInputVars further.

Let me know if this helps.

Thanks

October 15, 2018 at 8:01 pm #2818656

Marcel Elbers

ok it's 100% translated now but i don't see it on the front.

Thanks.

October 16, 2018 at 1:40 pm #2821138

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Please upgrade to WPML 4.0.7(the latest version) after a site backup. After that update the *Product Page 7* in the original language and the translated version(just resave). Then make sure the issue is existing or not.

If you are still having the issues, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

October 16, 2018 at 3:05 pm #2821475

Marcel Elbers

I think i know how to make the translation visible. Only on each product page this custom field "Single Product Divi Layout" must be visible. Can you tell me how i can make this custom field appear in the product wpml translation page?

Thanks.

October 16, 2018 at 5:01 pm #2821938

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please try the following steps and check you are getting the expected result or not.

1) Open a Product for edit in the default language
2) Scroll down to *Multilingual Content Setup* widget(on the bottom of the screen)
3) Choose *Translate* option for *Single Product Divi Layout* field
4) Click on *Apply* button
5) May you have to click on *Show system fields* link of *Multilingual Content Setup* widget to find the field

Please check the attached image and following documentation for more details, and let me know your feedback.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

--
Thanks!

Bigul

October 24, 2018 at 7:25 am #2845156

Marcel Elbers

My issue is resolved now. Thank you!