We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Hello, I am using WpResidence theme and trying to translate properties to second language. Everything is working fine except for the images. The translated property shows no images.

Solution: Make sure that the WPML Media Translation plugin is installed and active. Also, make sure that the Duplicate featured image to translations option is active in order to have the same featured image on the translation. Last but not least, make sure that all the elements from the side-by-side translation have the Translation is complete box checked (including the images).

This topic contains 10 replies, has 2 voices.

Last updated by mohamedM-27 3 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
August 4, 2019 at 10:26 am #4336091

mohamedM-27

I am trying to:
Hello, I am using WpResidence theme and trying to translate properties to second language.
everything is working fine except for the images. the translated property shows no images. I have two questions here:

1- I don't need to translate media. I want to use same media files for both languages.
I have checked your forum for the same issue but none of the solution worked.
after running Media translation only the featured image appears but not the other images.

I have tries to translate only one property and here is the results:
the original language:
hidden link

Translated version:
hidden link

2- how can i duplicate only property post type to the second language as a bulk

Thank you

August 5, 2019 at 10:28 am #4339825

mohamedM-27

Hello,

It has been more than 24 hours and I still did not get any answer from your side.
Please advise.Your help will be much appreciated.
Thank you

August 5, 2019 at 1:14 pm #4340737

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey,

Thank you for reaching out the WPML support!

Only a few of us are working during the weekend but now that it's Monday we're all here, ready to help you with your question.

Now, can you tell me if the images appear on the translated properties if you go to Dashboard → WPML → Settings → Post Types Translation and select the middle option (Translatable - use translation if available or fallback to default language) for the Media post type, please? This should do the trick for what you're looking for. Just give this a try and tell me how it goes.

Thanks,
Radu

August 5, 2019 at 2:29 pm #4341315

mohamedM-27

Thank you for your reply,
your trick fixed the images issue.
However, i appreciate your help with my second question
2- how can i duplicate only property post type to the second language as a bulk

August 5, 2019 at 3:21 pm #4341627

mohamedM-27

Back to the first issue,
I have tried to translate another property and now i featured image disappeared.
Also, i have noticed that there are 2 copies of each images in both original and translated record.
Please check this translated property
hidden link

you can see that the featured image is missing and the duplicated images as well

August 5, 2019 at 9:40 pm #4343135

mohamedM-27

Hello Radu,
Back to the first issue,
I have tried to translate another property and now i featured image disappeared.
Also, i have noticed that there are 2 copies of each images in both original and translated record.
Please check this translated property
hidden link

you can see that the featured image is missing and the duplicated images as well
2- how can i duplicate only property post type to the second language as a bulk
Please advise.
Thank you

August 6, 2019 at 9:11 am #4345645

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Mohamed,

You should be able to bulk duplicate the properties by following these steps:

  • go to Dashboard → WPML → Translation Management;
  • select the properties that you'd like to duplicate;
  • select the Duplicate content on the bottom of the page for the languages you want;
  • press Duplicate.

This should help you do the change in no time.

Regarding the issue about the images in the property that you tried to translate, I will need to have a closer look and see what's going on. In this case, can you give me access to the dashboard area, please?

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 7, 2019 at 7:45 am #4352527

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Mohamed,

I checked one of the properties here hidden link and I could see that on the Property Media that there are actually two of each image. Have you tried to remove the duplicate images, save the changes, and check again the property to see if the issue is gone?

Thanks,
Radu

August 7, 2019 at 9:04 am #4353025

mohamedM-27

Hello Radu,
Thank you for your reply, i was really expecting more than your suggestion to manually remove duplicated images!
However, NO, deleting duplicates manually didn't help, they are duplicated again.
I could just figure out the solution, and it is to activate "WPML Media" plugin again and the duplicates are removed.

For now, i still have the featured image problem, it is not showing in the translated record.
please check:
the translated record:
hidden link

The original record:
hidden link

PS, i would really appreciate your same day reply.
Thank you

August 8, 2019 at 8:52 am #4361169

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Mohamed,

I made some small changes to this listing hidden link and everything looks fine now on the translation too.

There is what I did:

  • I edited the original property;
  • checked the Duplicate featured image to translations checkbox on the right side;
  • hit the Update button;
  • edit the translation;
  • make sure that all the Translation is complete fields are checked;
  • hit the Save & Close button.

Once I did this, I just checked the translation once again and everything was looking fine hidden link. Can you have a look and tell me if the featured image looks good for you too, please?

Thanks,
Radu

August 8, 2019 at 10:09 am #4361661

mohamedM-27

Hello Radu,
Everything is working properly now.
My issue is resolved now. Thank you!