Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Using the WPML and WooCommerce, when someone makes a purchase the cart appears empty.

Solution: Could not replicate the problem that the client reported. This worked correctly and no problem was detected.

This topic contains 8 replies, has 2 voices.

Last updated by kamalpreetS 2 years, 4 months ago.

Assigned support staff: Bruno.

Author Posts
July 16, 2017 at 7:02 pm #1320355

kamalpreetS

I was having an issue with my checkouts on WooCommerce. When one language checks out it opens in another language checkout page. So my Canadian client clicks Checkout/Proceed to Order on the product but it redirects to the US checkout page. How can this be fixed? This is very urgent.

It ends up saying the cart is empty or the checkout page is completely blank.

July 17, 2017 at 1:00 pm #1320815

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us.

Did you have already created the WooCommerce pages for the secondary language? You can check this in WooCommerce > WooCommerce Multilingual > Status > WooCommerce Store Pages

On the WooCommerce > WooCommerce Multilingual > Store URLs, are URLs translated? Even if the value is the same, you should keep one version for each language.

Also, I noticed you are using a cache plugin. Have you tried clearing the cache to see if the problem persists?

If the problem persists, please as a test, could you disable all non-WPML plugins (keep WooCommerce and WooCommerce Multilingual) and see if the problem persists? If the issue is resolved, enable the plugins one by one to see which plugin is causing this problem.

Thank you.

July 17, 2017 at 4:01 pm #1321094

kamalpreetS

Hi there, see attached the screenshot. However, I do have separate WooCommerce pages installed but not translated since I didn't want to mix them up. I have a separate product in Canada and a separate product in the US. Thus, I don't want them to be mixed up. Please advise.

July 17, 2017 at 9:12 pm #1321364

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Note that translating the products should not mix them, and yet, they can keep them synchronized.

On product pages, it is possible that you keep these pages separate, but on these default WooCommerce pages, you should translate them by keeping them in sync.

You should click on the "Install WooCommerce Pages" link to create the pages for the secondary language.

After following these steps, please let me know if the problem persists.

Thank you.

July 24, 2017 at 2:42 pm #1325829

kamalpreetS

Hi Bruno, why should the products be translated? I kept them completely separate because they have their own individual links and prices through Gravity Forms. I can't apply the same Gravity Form to each product as the Gravity Form itself indicates the price. I went ahead and installed the WooCommerce pages but that still hasn't helped.

July 24, 2017 at 6:49 pm #1326060

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

For these product pages, it should be fine to keep them separate even though the content does not get mixed as long as each language page is individual in any way. But it should work properly as you are doing now and keeping the pages separate.

I started creating a purchase, but as the site is in production, I'm not finished. Up to this point, redirection is not done and this works correctly. I'll attach an image for you to see. Should I take some other step to see the problem?

Did you have already cleared your browser data to test? If you're using Google Chrome, you can click Tools > More tools > Clear browsing data.

Thank you.

July 26, 2017 at 4:04 pm #1327798

kamalpreetS

Hi Bruno, yes that's working as you mentioned. Some customers are saying their cart is just empty when proceeding to order and it doesn't work which is odd. I guess it's not a WPML issue?

July 26, 2017 at 8:42 pm #1327995

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Probably not. Note that if the client clears the browser data or uses the "window private"/"incognito window" browser's feature, closing the browser and reopening the products must have been removed from the cart, but this is because the user has cleared the navigation data.

Other than that, this does not seem to be affected by WPML.

Thank you.

August 4, 2017 at 4:22 pm #1335490

kamalpreetS

Hi Bruno, it looks like the issues still happening. However, this issues slightly different. The cart is empty and the checkout page is in the right country: hidden link

Gravity Forms & WooCommerce said there's no issues from their end. Can you please find out what's going on?