This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 3 months ago.

Assigned support staff: Noman.

Author Posts
July 7, 2019 at 10:46 am #4157619

paolaO

I would know the way to insert flags on the right side of header.
Flags appears only in the footer. The wordpress theme is Bridge.

Could you help me?

website: hidden link

Thank you very much
Marco

July 7, 2019 at 1:11 pm #4157725

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. The possibility to add your language switcher on that position depends on your theme. Does your theme provides you the option to add a content (for example a widget) or some code exactly on the position that you wish?

You can use below code to show custom language switcher on specific position:

do_action('wpml_add_language_selector');

Here is doc for custom language switcher:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#custom-locations

Please let me know if this resolves your issue or you need further assistance.

Thank you

July 12, 2019 at 2:01 pm #4199537
paolaO

Hi,
thank you very much. But now i've another issue, could you help me?
I can't add transleted page anymore. WordPress sand me a mail with this error:

Dettagli dell'errore
====================
Un errore di E_ERROR è stato causato nella linea 32 del file /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php. Messaggio di errore: Uncaught InvalidArgumentException: element_id and type do not match for element_id:18322 the database contains post_attachment while this function was called with post_page in /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32
Stack trace:
#0 /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1489): WPML_Set_Language->set(18322, 'post_page', '15562', 'en', 'it', true)
#1 /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(325): SitePress->set_element_language_details(18322, 'post_page', '15562', 'en', 'it')
#2 /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(172): WPML_Post_Translation->maybe_set_elid('15562', 'page', 'en', 18322, 'it')
#3 /home/robertcutty/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/post-tra

could you help me?

Thankyou

Marco

July 14, 2019 at 12:48 pm #4205569

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To handle new issue, I have created a new ticket since this is a separate issue. Here is the link to the new ticket:
https://wpml.org/forums/topic/uncaught-invalidargumentexception-element_id-and-type-do-not-match-for-element_id/

Thank you for your cooperation and patience.