This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.36 hours from now. Thank you for your understanding.

This topic contains 14 replies, has 2 voices.

Last updated by Jesper 2 weeks, 4 days ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 23, 2019 at 12:34 pm #4623921

Jesper

On the website hidden link, when on the home page, clicking any of the countries in the dropdown in the header, takes you to the news listing page of the selected country. It should take you to the home page and not the news page. However, this is only a problem on the home page, since if you navigate to another page on the site and use the dropdown, it takes you to the correct page for that language.

I am not sure if it is related, but we also noticed that when viewing hidden link, the domain is completely wrong in 'view source'. Could this be a licensing issue of some kind? Is this something you are able to check?

Please could an admin also hide all domains from this message to the public?

September 24, 2019 at 2:28 am #4627303

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Have you translated the frontpage? Is it a static page or an blog page?

Can you change the language URL format to another format (language parameter) and see if that helps?

Regarding the different domain error, is the domain that's showing in the results is related to your site? Is it hosted on the same folder as shown in URL?

Look forward to your reply.

Thanks

September 24, 2019 at 7:41 am #4628657

Jesper

Hi Shekhar,

Have you translated the frontpage? Is it a static page or an blog page?
Yes we have translated the page, and it is a static page.

Can you change the language URL format to another format (language parameter) and see if that helps?
Yes, this does help. It works if we change the format to a parameter. Is it possible to get this working with directories? It looks nicer for users and I believe it is also preferable for SEO.

Regarding the different domain error, is the domain that's showing in the results is related to your site? Is it hosted on the same folder as shown in URL?
The domain is related, since the site is a multisite, but if that is not related to the problem we are having with the home page, then I'm not too bothered about fixing this one.

September 24, 2019 at 8:06 am #4628941

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, let me check why the directories is not working, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

September 25, 2019 at 8:44 am #4636921

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

As the warning message mentions can you please fix those properly with your hosting provider help?

- Make sure url rewriting is enabled
- .htaccess is writeable
- WordPress is not installed in directory

Let me know if this helps.

Thanks

September 25, 2019 at 11:45 am #4638381

Jesper

I don't understand why those errors are showing, because the .htaccess is already writable by the server (775), RewriteEngine is already On, and WordPress was never installed in a directory. What else can cause this error?

September 26, 2019 at 1:58 am #4642459

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Probably there is something that's not done properly from server side? Can you check with them once if this services are enabled from there side? sometime changes we made should be done in the server itself so please consult with them once.

Thanks

September 26, 2019 at 6:49 am #4643753

Jesper

I have checked the server myself, and the rewrite module is definitely activated. To test this, I used:

sudo a2enmod rewrite

Response received:

Module rewrite already enabled
September 26, 2019 at 8:54 am #4644655

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since we have tried almost all steps we would need login details to see why it's not working, so can you please provide me login details in the next private reply?

Look forward to your reply.

Thanks

September 27, 2019 at 2:30 am #4651045

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see few errors happening on the console.

SyntaxError: Unexpected token y in JSON at position 0

This is happening with the wp time console plugin, so can you disable it once and save the language format once? or you provide me permissions to disable/enable plugins themes?

Look forward to your reply.

Thanks

September 30, 2019 at 7:04 am #4662559

Jesper

I am assuming you mean "WP Time Capsule"? If so, I have deactivated this plugin, and I have also saved "Language URL format" again, but this has made no difference.

September 30, 2019 at 7:44 am #4662703

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Ok I checked it further and noticed that on the front-end the language directory is working properly except the home page url where it's redirecting to a certain blog url.

Upon further debugging I noticed that you have added a redirection, so I deleted it and it's working perfectly, can you please confirm?

Look forward to your reply.

Thanks

September 30, 2019 at 12:40 pm #4664633

Jesper

"Ok I checked it further and noticed that on the front-end the language directory is working properly except the home page url where it's redirecting to a certain blog url."

Yes, this is what I said was the problem in my original question.

I have just checked and this problem is still not resolved. I have cleared my browser cache and checked in 'incognito' mode. Please can you also confirm where exactly you found this redirection you mentioned? We require a full log of any settings you are changing so that we can revert if we need to.

October 1, 2019 at 2:09 am #4668043

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I found the settings in redirection plugin and deleted the entry that redirected the /zh-hans/ I checked it again to provide a absolute path but it looks like the redirection plugin is now disabled.

Also, I checked the issue and it's working perfectly for me, so can you please let me know if the problem still happens for you?

Look forward to your reply.

Thanks

October 1, 2019 at 7:13 am #4669101

Jesper

My issue is resolved now, thank you for your assistance.