This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to copy content translated to new translated pages using Visual Composer.

Solution: Create a VC template from each page and then import the template into the page you desire to copy the content to.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 12 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 11, 2018 at 11:36 am

sebasO

I'm building a site with Visual Composer. I've created 3 pages for professors and all of them are translated to english and to catalan. If I copy all the rows in these pages and I paste them in a new page (I would like to have all professors in one page, not in three), this new page doesn't copy catalan nor english texts, it just copy the original texts to the new languaje fields.

Link to a page where the issue can be seen:

Please go to admin > pages > All pages > profesores urbanismo. All is translated frome spanish to catalan and english (I've copied all the content of this page and I want it in the new page)

Please go to admin > pages > All pages > profesores restauracion. All is translated frome spanish to catalan and english(I've copied the content of this page and I want it in the new page)

Please go to admin> pages> profesores (this is the new page with all professors). Check translations: both english and catalan are now in spanish 🙁

That means I have to translate EVERYTHING AGAIN, what it's really awful because editor is not ordered and I have to find eeeeevery text in my hundreds of word docs again.

Please do something...

October 12, 2018 at 4:07 am #2810723

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

1.- In this case I recommend you to follow this steps:
-- Edit the page in Spanish -> Copy the content -> Create the new page in Spanish -> Paste the content -> Save the pages.

After the step above you should have two pages in Spanish with the same content.

-- Edit the page in Spanish -> Switch language to Catalan using the language switcher in the admin menu (top of the page) -> Click on the pop up the option to keep editing the page -> Copy the content -> Edit the new page in Spanish -> Switch language to Catalan in the admin menu -> Click on the pop up the option to keep editing the page -> Paste the content -> Save the page.

This time you should end up with having the same content in the new page in Spanish and Catalan. Do the same for English.

Note: When you translate a page/post using the Translation Editor, the changes in the content made in the Translation Editor will overwrite the content made manually.

Could you confirm that this issue is solved?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 12, 2018 at 11:20 am #2811731

sebasO

Hola Carlos:
Veo que hablas castellano, si también es tu idioma nativo prefiero escribir en castellano entonces.

Te digo el proceso que he hecho porque sigue sin funcionar correctamente, creo.

1. He creado una página "profesores 2" y he copiado todo el contenido de "profesores 1" en español.
2. He hecho el switch en "profesores 2" a catalán.
3. He ido copiando los contenidos en catalán de las otras 3 páginas que quería copiar y los he pegado en "profesores 2" versión catalana.
4. También he cogido los contenidos de "profesores 1" que solo había creado en esta página y que no existían en otras, y también los he pegado en "profesores 2" versión catalana, esperando que una vez armada la página, el editor de traducciones de WPML funcionaría y podría traducir después el contenido de esos trozos que hasta ahora existían en castellano.
O sea, ahora tengo una página "profesores 2" toda en español y otra "profesores 2" casi toda en catalán pero con algunos trozos en castellano porque solo existían en castellano.

5. Repito todo ese mismo proceso en "profesores 2" en inglés.
6. Guardo todo y cuando abro de forma normal la página "profesores 2" en su idioma original, español, veo que en la parte de la derecha, donde deberían aparecer los idiomas catalán e inglés con un icono de un lápiz al lado, aparecen con un símbolo +.
Si entro tanto en catalán como en inglés con el editor de WPML, todas las cajas aparecen vacías, como si no existieran traducciones.

Así que, aunque ahora en el navegador ya tengo mi página en los 3 idiomas, el editor no funciona. Y eso no es una solución porque habrá que seguir añadiendo contenido a esa página en un futuro y no lo haré yo sino la persona para la que estoy haciendo la web, a la cual no le puedo decir que a veces el editor funcionará y a veces no.

No sé si me explico... Por favor puedes echar un vistazo en la admin?
Hay alguna forma de sincronizar todo ese nuevo contenido para que el editor de WPML lo reconozca??

Por cierto, he hecho todo el mismo proceso en la página origina "profesores", editando la versión ingles y catalana de la misma desde la parte de páginas de la admin, y tampoco funciona el editor de WPML: sigue teniendo todas las cajas copiando el español.

Es como si ahora hubiera un contenido quintuplicado: la página original, la página en catalán, la página en inglés, la no-traducción al inglés en el editor de wpml (que está en español) y la no-traducción al catalán de wpml (que está en español)

Por último, cunado instalé wpml entré en el cpanel del servidor y cambié el límite de memoria a 256. He vuelto a entrar en el cpanel para comprobar lo que me decías y efectivamente me aparece que está en 256. Dónde has comprobado que está a 128 o menos?

Gracias.

October 12, 2018 at 7:09 pm #2812948

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

1.- He consultado con mis colegas este problema y cuando se copia manualmente el contenido en las páginas traducidas, dicho contenido no se sincroniza con el Editor de Traducción.

La causa de este comportamiento es que se intenta utilizar dos maneras de traducir distintas, la traducción manual y el editor de traducción.

Si desea seguir utilizando el Editor de Traducción los pasos correctos serían los de copiar el contenido de la página en el idioma original y luego traducirlo con el Editor de Traducción. Por el contrario si desea editar el contenido de manera manual entonces debe ir a WPML -> Settings -> How to translate posts and pages -> Seleccionar 'Create translations manually' -> Guardar los cambios.

2.- Con respecto al límite de memoria, éste lo puede verificar en WPML -> Support.

Por favor hágame saber si necesita más asistencia de mi parte y estaré mas que contento de poder ayudarle.
Saludos cordiales,
Carlos

October 12, 2018 at 7:18 pm #2812954

sebasO

Hola Carlos:
Entonces entiendo que WPML tiene un enorme fallo... no puede ser que una página ya traducida, con contenido traducido, la copie a otra página y el contenido no se traduzca. No tiene sentido y pienso que es algo que WPML tiene que solucionar.
yo no quería usar el traductor manual en primera instancia, es lo que me has ofrecido como solución y no es una solución.

Una cosa que se supone que tiene que ser eficiente, por la que pagas un dinero además, es lo más ineficiente del mundo... la única solución que me paortáis es que vuelva a traducir un contenido gigante que ya había traducido.

Y además, el traductor de wpml no carga los campos ordenados como están en la página original (con bloques de Visual composer) así que hay que buscar bloque por bloque, texto por texto... es una locura y la verdad que tu respuesta me ha dejado desesperada.

En fin, muy mal, de verdad. Me dan ganas de pediros que me hagáis vosotros toda la copia de textos, ya que me parece que he pagado por hacerme perder montones de horas.

Pido disculpas por mi cabreo pero espero que entiendas que no me dais ninguna solución.

October 12, 2018 at 7:57 pm #2813015

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Entiendo su frustración y le pido perdón por las inconveniencias.

La causa del problema es que la lógica de WPML en cuanto a traducción de posts es la de seleccionar un método de traducción (Manual, Editor de Traducción Clásico o Editor de Traducción Avanzado), editar el post en el idioma original y luego traducir el contenido.

Su necesidad de copiar manualmente un contenido traducido a una nueva página en un idioma secundario y sincronizarlo con los campos del Editor de Traducción no está contemplado en la lógica original del plugin.

Entiendo que esta explicación no resuelve su problema original, pero espero que la comprenda.

En este punto sólo quedaría la alternativa de hacer una solución personalizada que cae fuera del alcance de nuestro servicio de soporte. Para ello le puedo recomendar que contacte con uno de nuestros socios certificados en el siguiente enlace: https://wpml.org/contractors/

Muchas gracias por su comprensión y perdone las inconveniencias causadas.
Saludos cordiales,
Carlos

October 13, 2018 at 12:10 pm #2814096

sebasO

Hola Carlos:
Bueno, pues dándole vueltas a la cabeza, al final he conseguido una solución.

Resulta que guardando las 3 páginas que quería copiar y luego pegar en una nueva como "templates" según el sistema de Visual Composer, así se pega el contenido y sus traducciones.

No sé cuál es la lógica de WPML pero hay algo en la respuesta que me diste que no tiene ninguna lógica... Y tampoco sé qué lógica tiene que sí funcione con el método de templates de VC, pero funciona.

Eso sí, funciona si se pegan todos los templates y luego ya se pasa a la parte de editor de traducción. Si pego un template, edito traducción y luego pego otro template, entonces de nuevo no funciona.

Supongo que WPML quiere mejorar y bla bla bla... así que estaría muy bien que la gente del equipo técnico revisase estas cosas.

Lo que de verdad no puede ser, NO PUEDE SER es que no se pueda copiar un contenido ya traducido de una página a otra página. Eso no tiene ninguna lógica, ninguna.

Ni que sea haciéndolo mediante traducción de strings... si los textos originales coinciden, los textos traducidos no se repiten! Vaya, además de webs en WordPress he hecho muchas a medida y en los archivos de traducción una misma frase, si está escrita igual, nunca está dos veces.

Porque, me pregunto: entonces qué pasa con la página "profesores" en la que hay traducciones distintas según si abres el editor de traducción o si abres la página cn el switcher? Hay una zona en la base de datos donde hay todo ese contenido duplicado? No crea eso incongruencias y finalmente algún tipo de error de php o bbdd?

Es que de verdad que no puede ser lógico!

Marcaré este post como resuelto (aunque no por vuestra parte) pero me gustaría que en la parte de arriba se pusiese esta posibilidad de crear templates como solución para otra gente que tenga el mismo conflicto (relamente no me puedo creer que yo sea la única a la que le ha pasado) y que se hable con el equipo técnico/programación para ofrecer un sistema eficiente y lógico (pero lógico de verdad) para este tipo de situaciones.

October 16, 2018 at 3:07 pm #2821492

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su mensaje.

Me alegra saber que encontró un 'workaround' para este problema. Voy a informarle a nuestros desarrolladores acerca del tema para que echen un vistazo en mayor profundidad y en caso de ser necesario se escalará este ticket a nuestro segundo nivel de soporte.

Saludos cordiales,
Carlos