This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Andrey 2 years, 4 months ago.

Assigned support staff: Andrey.

Author Posts
April 5, 2017 at 12:55 pm #1247825

szilardM-2

Hi!

I use WooCommerce Multilingual plugin with all the necessary other WPML plugins.
I use WooCommerce Membership extension too.
If WooCommerce Multilingual is activated I got an 404 error if I click on a membership plan under my account/dashboard, where all the active memberships are listed for the user.
If I deactivate WooCommerce Multilingual (only this plugin, nothing else), than everything is working fine, if I click on a membership plan it loads in the details and submenus of that membership.

Could you help, what can be the problem?

Best,
Szilard

April 5, 2017 at 2:45 pm #1247967

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello Szilard,

This issue has been already escalated to our compatibility team in order to debug and contact the WooCommerce Memberships plugin author.

Please note that this process may take a while as it depends on different factors and how soon the author will reply to our efforts to contact him.

I'll add your ticket to our records. You will be notified the moment we have any progress on this.

Thank you for your understanding.

April 5, 2017 at 3:05 pm #1247987

mariekeK-2

I have the same issue. I noted that I do no longer get a 404 if I just deactivate the translation management plugin and play around with resaving permalinks (tip from woocommerce) but, this does not solve the issue completely, because i have connected content to the membership and that does not show. This is part of the same problem.

April 5, 2017 at 3:28 pm #1248028

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

As @Szilard mentioned, and he's right, there's a conflict with WooCommerce Multilingual and WooCommerce Memberships plugin. When you deactivated WPML Translation Managment, then WooCommerce Multilingual plugin would not work any longer, that's why you noticed no error.

I hope that a solution will be found soon. I'll keep you posted.

April 5, 2017 at 3:40 pm #1248040

mariekeK-2

Well... this is not entirely true, my site hidden link is still multilingual, but members logging in do not see content associated with their membership. Technically it does work though, hidden link can only be seen when logged in. The funny thing is that this problem already occured in the test situation and was resolved by stopping all plugins, resaving permalinks and putting them back on, but now it only works if I keep the translation management out of the equasion.

April 5, 2017 at 3:53 pm #1248054

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thanks for the information. I just wanted to say that WooCommerce Multilingual plugin doesn't work at all (it means that WPML and Woocommerce do not play nicely then) if any of WPML required components is not activated.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

As soon as I have more news on the initially reported issue here, I'll update everyone.

April 5, 2017 at 4:07 pm #1248063

mariekeK-2

Well.. my spanish site still works, spanish shop/membership and subsription is not activated yet. And i do get the message on my dashboard that indeed woocommerce multilanguage is not working. So, you are right too.

April 7, 2017 at 7:55 am #1249498

mariekeK-2

Question: are you solving this for woocommerce 2.x or for 3.0? I am running 2.x

April 7, 2017 at 8:08 am #1249511

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

It should be working for both versions, but I can't say how fast it will be solved as not everything depends on us.

April 8, 2017 at 11:36 am #1250379

szilardM-2

Hi Andrey,

Thanks for the info, let me know if you could solve this issue.

Best,
Szilard

April 13, 2017 at 12:48 pm #1253756

szilardM-2

Hi Andrey,

The guys at WooCommerce say they didn't receive any email from you.
"I just wanted to let you know that we still do not receive any email from WPML, but we will keep an eye out for it!"

Please check it.

Best,
Szilard

April 13, 2017 at 3:04 pm #1253897

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello Szilard,

Thank you for bringing this to our attention. I have checked this with the development team. It's possible to fix the issue from our side.

I'll keep you posted.

Thanks,
Andrey

May 30, 2017 at 1:13 pm #1287379

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thank you all for your patience! The issue is no longer exists with the latest version of Woocommerce Multilingual.

The plugin can be updated from the plugins page.

Make sure to take a full backup of your site before you proceed.