Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 3 voices.

Last updated by Noman 3 weeks, 2 days ago.

Assigned support staff: Noman.

Author Posts
January 6, 2020 at 9:12 pm

John-Pierre Cornelissen

On this website I have three pages that contain an iframe to show content from another site. But the iFrame doesn't show on the translated page.

1) This reservations page has an iFrame to a reservation widget from The Fork.
hidden link
* It's in a Divi code module as a global library item. I translated it in the library and even tried to translated by disabling the 'hidden link' setting, but it doesn't work.
* Then I also tried with a regular text module and that doesn't work either

2) On the bottom of this page at the bottom there is an iframe that loads a 3D image from Google My Business that doesn't show in the translation. This one is in a Divi code module.
hidden link

3) At the top of this page there is a Google Maps module that loads in an iFrame. Also in a Code module.
hidden link

How can I fix this?
Thanks
JP

January 7, 2020 at 1:11 pm #5247071

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. As we have discussed this issue on chat and you can reply me here if still issue persists.

Thank you

January 7, 2020 at 1:31 pm #5247123

John-Pierre Cornelissen

Part of the discussion here
https://wpml.org/forums/topic/translation-not-shown/

January 7, 2020 at 1:39 pm #5247203

John-Pierre Cornelissen

Ok, so I could reproduce it in my test version.
After disabling all plugins, I could translate into another language and that worked.
But the original translation won't update.

This source
hidden link

I translated to English and it won't show the iframes
hidden link

Then I disabled all plugins and translated into German, that worked
hidden link

So then I tried to update the English translation, but it won't fix the missing iFrames

Any idea why?

January 7, 2020 at 1:54 pm #5247355

John-Pierre Cornelissen

I think it's related to WordFence.

When I enabled that plugin again and updated the German translation, the iframe was also gone.

But then I disabled the plugin again, but if I change the source and update the translation, the iFrame doesn't come back.

It shows when I finish the translation (see screenshot), but it seems it is stripped out when I hit complete.

January 8, 2020 at 7:47 am #5251885

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to deactivate and reactivate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

January 8, 2020 at 9:25 am
January 9, 2020 at 8:46 am #5259629

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for login details, but WP login info that you have provided is not working here. Can you please provide me working login to debug this issue further, your next reply will be private.

Thank you

January 9, 2020 at 10:33 am #5260495

John-Pierre Cornelissen

Hi, it does work for me, but I forgot to add the wp admin login url so you probably went to the live website in stead of the test site. I update the previous private message. Please have a look. Thanks.

January 12, 2020 at 10:14 am #5276127

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for the delay, we ran into the weekend. I have logged in to your site and followed below steps:

1. Opened this page hidden link as Edit mode.
2. Opened English translation of this page and completed the translation.
3. Then visited the frontend of English page and it showing iFrame correctly.
4. Then I have enabled Wordfence security plugin.
5. Opened German translation of this page and completed the translation.
6. Then visited the frontend of German page and it showing iFrame correctly.

Could you please clear your browser cache and take another look on it or please let me know if I missed something.

Thank you for your patience and cooperation

January 12, 2020 at 10:43 am #5276147

John-Pierre Cornelissen

Hi Noman, thanks, I can see it did translated. Weird. Did that work just like that, or did you change a setting in WPML or the AT?

I changed something on the page and tried to translated myself. Although it did translate, the translation of the code module still goes wrong. Have a look:
hidden link

Looking at the source it dropped the % from the width setting, see attached.

January 12, 2020 at 11:30 am #5276213

John-Pierre Cornelissen

Addition

There is something really weird going on here.

I also added the iFrame with the Google Map and one with Google Street View to that page.
hidden link

Then I translated into English: it doesn't show the iFrames
Then I translated into German: it does show the iFrames

I don't see why it doesn't correctly translate into English while it does translate into German.

January 13, 2020 at 7:01 am #5279303

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I didn’t change any settings, I just opened the page and completed the translation and nothing else.

Percentage (%) sign also exist in the source code of the translated page.

It’s working fine for me on English page too as you can see in the attached screenshot.

Could you please try different browser and I hope it will resolve your issue.

Thank you

January 13, 2020 at 7:31 am #5279511

John-Pierre Cornelissen

That's really weird. How can it be that one language works for me and the other doesn't?

January 13, 2020 at 2:12 pm #5283259

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry, I’m not sure why this happening in your side. I’m using the latest Chrome browser in Windows 10 operating system and all languages working fine for me.

Thank you