We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by pierreG-4 1 month ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 3, 2019 at 8:09 am #4685577

pierreG-4

Mr Jamal à fait une intervention très satisfaisante sur le site mais j'ai cherche dans les option de wpml pour afficher les drapeaux sur le menu du site et manque des options comment je fait
Merci

October 3, 2019 at 7:23 pm #4691025

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

You should be able to find the language switcher option inside WPML > Language.

Here is also more information regarding this:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please let me know how that goes and if you still need help.

Kind regards,
Mihai Apetrei

October 4, 2019 at 5:24 am #4692809

pierreG-4

Bonjour,

je sais que c'est dans "Language" mais l'option n'est pas la ci-joint la photo qui montre qu'il manque des option Il n'y à pas

Merci

October 5, 2019 at 8:27 am #4700133

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the confirmation.

1. Can you please let me know what version of WPML you have installed?

2. Can you please let me know if the "language" tab appears if you disable all the non-WPML plugins and leave just the WPML plugin active?

Please let me know how that goes.

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

October 7, 2019 at 10:42 am #4706321

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the credentials.

I was able to log into the backend.

Can you please try this:

1. Create a full website backup first
2. Go here (hidden link) and:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know if that solves the issue.

Kind regards,
Mihai

October 8, 2019 at 7:29 am #4712793

pierreG-4

Bonjour j'ai tester tout votre astuce mais rien ne fonction il y à un bouton dans le menu qui montre " Ajouter un sélecteur de langue" mais il me dit que je ne suis pas autoriser pour tant je suis l'admin je croix que c'est une bug. Est ce que vous pouvez faire une intervention parce que la c'est inutile de faire le multilang sans les lang affiche sur le front au niveau de l'installation il y avez déjà une bug dans WPML et le support a réaliser une requette pour qu'il a réussie à faire l'installation mais la il manque les option
merci de faire l'intervention

October 8, 2019 at 1:28 pm #4715807

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Whenever I try to access the WPML > Languages area (this is the place from where we should normally add the language switcher - hidden link), I receive the error that you see in the screenshot below.

There seems to be a user permission issue on your site that is not allowing our plugin to show all the tabs.

1. Can you please create a full backup of the site.

2. Please go here (hidden link) and update the plugins to the latest version

3. Can you share in the link below the FTP/SFTP credentials to the site? Also, can you please share the main WordPress admin credentials of the first user admin that was created on the site?

Kind regards,
Mihai

October 8, 2019 at 1:37 pm #4715883

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

It seems that you were experiencing the same issue as here (https://wpml.org/forums/topic/wpml-sorry-you-are-not-allowed-to-access-this-page/).

I just applied the same steps in the solution that you see in that link (I added that code to the end of the functions.php file in your theme and I refreshed the homepage once) and that solved the issue.

Now you can see all the WPML tabs in the backend and you can go to WPML > Languages and set the language switcher.

Kind regards,
Mihai

October 8, 2019 at 2:18 pm #4716323

pierreG-4

bonjour Mr Mihai;
je vois bien que vous avez résolue le problème des options mais j'ai encore un soucie j'ai paramétré la lang ci-joint en image mais rien ne s'affiche sur la front-end du site est ce que vous avez une idée ou j'ai oublier un truc
merci

October 8, 2019 at 2:41 pm #4716409

pierreG-4

My issue is resolved now. Thank you!