If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Radu 3 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
July 30, 2019 at 3:27 pm #4309187

ivanC-39

Hi,
I'm encountering these warning messages in two pages:

Warning: Illegal offset type in isset or empty in /web/htdocs/www.mac-place.com/home/wp-content/plugins/sitepress-multilingual-cms/inc/taxonomy-term-translation/wpml-term-translation.class.php on line 38

Warning: Illegal offset type in isset or empty in /web/htdocs/www.mac-place.com/home/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247

Warning: Illegal offset type in isset or empty in /web/htdocs/www.mac-place.com/home/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 257

Warning: Illegal offset type in /web/htdocs/www.mac-place.com/home/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 258

Warning: Illegal offset type in isset or empty in /web/htdocs/www.mac-place.com/home/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 262

I saw similar tickets but since it's another path and things are slightly different I preferred to ask.
Thank you

July 31, 2019 at 5:07 am #4311473

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Ivan,

Thank you for reaching out the WPML support!

Can you attach a link to the two pages where you see the warning messages, please? Also, can you temporary deactivate all the plugins not related to WPML, activate a default theme (like Twenty Nineteen), and tell me if you still see these warnings? This way we can see if this is cause by one of the plugins you're using.

Thanks,
Radu

July 31, 2019 at 9:23 am #4313267

ivanC-39

Hi Radu,
Here the two pages:
hidden link
hidden link

We tried to deactivate all the plugins except for the WPML ones and we activated a default theme and we still se those warnings.

Thank you!

August 1, 2019 at 10:51 am #4320757

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Ivan,

Thank you for sending me the two links. These warnings were an issue in a previous version of the ACFML plugin but everything should be back to normal now. Can you give me access to the dashboard area of your website so I can have a closer look at this, please? The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 1, 2019 at 12:26 pm #4321415

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Ivan,

Can you try to deactivate all the plugins not related to WPML and Motors - Classified Listing, and tell me if the warnings from the top of the page are still displayed, please? Also, did you see these messages only on the listings archive? I want to see if this is related only to listings or not to narrow down the parts that might be causing this issue.

Thanks,
Radu

August 1, 2019 at 1:12 pm #4322117

ivanC-39

Hi,
we deactivated all the plugins and left active only those concerning WPML and the Motors theme.
Still seeing the warning messages.
I confirm you that we only see the errors in the two links we attached you in the prevoius messages, so we only see them in the pages where the Listing is used.
Thank you!

August 5, 2019 at 9:48 am #4339455

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Ivan,

I made a few more tests on your website and I could see that these warning messages appear only when you select any filter option from the left sidebar and refresh the page. Basically, that [0] part added to the URL is the one causing the issue.

For example, you can compare this page hidden link with this one hidden link

Also, this happens only when just one filter option is selected. If you check this link hidden link, you can see that two filter options are selected, the [0] is available in the link, but the warning messages are not available.

In this case, is there any chance that you could reach out the theme author and ask him if there's any chance to get rid of that part which doesn't seem to make any difference on the functionality side (things look the same with or without that [0] part), but makes these warnings appear? You can let me know if they ask for any help from our side.

Thanks,
Radu

August 12, 2019 at 1:06 pm #4381053

ivanC-39

Hi,
thanks, we will reach the theme's authors then.
Is there any way I can temporarily hide those errors?
I tried with define('WP_DEBUG_DISPLAY', false); and define('WP_DEBUG', false); in the wp-config.php file but the errors are still displayed.

Thank you!

August 13, 2019 at 6:25 am #4385229

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Ivan,

Can you try to add this too to the wp-config.php file:

define( 'SCRIPT_DEBUG', false );

and tell me if the errors are no longer displayed, please? Also, make sure that there's no code on this file that sets the debug to true because the one that makes it false will be overwritten.

Thanks,
Radu

The topic ‘[Closed] Illegal offset type’ is closed to new replies.