If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 18, 2018 at 6:38 am

muhammadB-3

1: Im getting a blank page on a translated page ?
2: When i try to edit arabic content admin panel goes RTL and css gets miserable?

September 19, 2018 at 2:22 am #2746918

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you provide an example of a page where this issue is happening?

2.- You can set your admin language in your profile page by following this steps:
- Edit your profile -> Languages -> Select the admin language you desire to have in the backend -> Under 'WPML language settings' -> Make sure to deselect the 'Set admin language as editing language' option -> Save the changes.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 19, 2018 at 6:26 am #2747390

muhammadB-3

Dear carlos,
a humble request since my client is waiting and yesterday was my deadline of this project.
please expedite the resolution

Your all above requirements i did. nothing changed.

1: After your some modifications to site now the home page in English is showing a Arabic product.

2: In Shop this error is showing up :-

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 130968 bytes) in /home/quickcobon/public_html/wp-includes/class-wp-term-query.php on line 288

3: I have translated About us page here is the link : hidden link
this page also showing error now :-

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1280 bytes) in /home/quickcobon/public_html/wp-content/plugins/js_composer/include/templates/shortcodes/vc_row.php on line 37

4: And in homepage if try to change language from language switcher to Arabic this error shows up:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 65552 bytes) in /home/quickcobon/public_html/wp-includes/shortcodes.php on line 352

Waiting for your feedback,

September 19, 2018 at 7:09 am #2747516

muhammadB-3

Dear Carlos,
i figured out that Memory limit had to be changed from user.ini after that the error are gone but facing another issue,

Please now consider below questions:

1: When trying to Translate a page only standard translator pop's up but i want to edit the Arabic page in WPBakery not in standard WPML Translator editor? So i can have different rows and structure of pages in Arabic content.

2: Footer are being managed in woodmart through html block and i want assign a different HTML Block to footer in Arabic Language pages .

3: when i shift back to Arabic in Admin panel many texts are still in English need to change all of them in Arabic?

Waiting for your reply.

September 19, 2018 at 4:26 pm #2749459

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I'm glad to hear that the original issues are solved 🙂

1.- In order to change the translation method you need to go to WPML -> Settings -> How to translate posts and pages -> Select 'Create translations manually' option -> Save the changes.

2.- About this issue, I kindly ask you to open a new ticket and assign it directly to me. Please provide the steps to reproduce the issue in the new ticket.

3.- Yes, you can translate this strings to Arabic in WPML -> String Translation.

Best regards,
Carlos

September 20, 2018 at 8:24 am #2751431

muhammadB-3

Just Figured out still having problem in shop page trying edit it and this error shows up


Fatal error: Out of memory (allocated 194772992) (tried to allocate 1773568 bytes) in /home/quickcobon/public_html/wp-includes/functions.php on line 3743

September 20, 2018 at 5:55 pm #2752924

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

1.- That error can be solved by contacting your hosting providers. Please contact your hosting providers and ask them to increase the memory limit assigned to your site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Best regards,
Carlos

September 25, 2018 at 9:45 am #2763254

muhammadB-3

Carlos,
This is really miserable..!
1: i want to edit my translations in WPBakery even after assigning "Creating Transations Manually " Doesnt work?!
2: After Changing the default language to Arabic and user profile in English every time it redirects and show in arabic whole admin panel, sometimes some text some text in English and some text in arabic
3: I want to give all translation WPML access to "Shop Manager" or "Editor" i dont want the whole story of translations job and etc !!

September 25, 2018 at 6:52 pm #2765042

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

1.- I double checked the configuration and it is correct. I tested it with one of the About pages and it is working as expected. If you still see this issue, please describe the steps you are following in order to reproduce the issue.

2.- I'm sorry but I don't understand what do you mean in this point. Please attach some screenshots to help me understand the issue.

3.- In this case you need to grant this users admin access or add them as translators in WPML -> Translation Management.

Best regards,
Carlos

September 30, 2018 at 11:06 am #2776436

muhammadB-3

Dear Carlos,

Our Site is are very slow after WPML? Extremely slow in both front-end and back-end .
Kindky help...!

Waiting for your response.

Need to Finnish the project.

September 30, 2018 at 4:14 pm #2776653

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I kindly ask you to open a new ticket as the performance issue is different that the original issue. This way we will be following the forum's rule of one issue per ticket. It will also help future clients to find answers to similar questions in the future.

Note: I recommend you to visit this link where you might find helpfull information: https://wpml.org/2012/01/can-your-site-run-faster/

Best regards,
Carlos