This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by murrayB 4 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 27, 2019 at 5:11 pm #3899819

murrayB

I am trying to: Use WPML

Instead, I got: A Content Error on every page not allowing me to use Fusion Builder anymore! I tried installing Classic Editor, as was suggested back in December but to no avail.

May 27, 2019 at 9:37 pm #3901111

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 768M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

In case this will nto solve the issue please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to see errors on a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 27, 2019 at 10:16 pm #3901149

murrayB

Thanks for your help!
Your fix seems to have fixed every page except my Home page (English), where I'm still getting the error

May 28, 2019 at 6:57 pm #3909645

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 30, 2019 at 12:47 am #3919263

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for providing access to your website.

The content error when opening the Fusion Builder also appears if any other plugin is deactivated. This is why the issue is not related or WPML or another third plugin, it is further mentioning that there is an eroor inside the text content.

It might be that you edited the text by mistake. The text inside of your page builder is build on base of Fusion Builder shortcodes, which for I would advise you to contact the Theme Fusion Support here:
hidden link

Do not hesitate to contact us if you need any assistance in regards to the translations with WPML.

Kind regards
Andreas

May 30, 2019 at 12:49 am #3919265

murrayB

Alright I'll look into it more that way, I thought it was because it only came up once I made a French page for it!
Thanks so much for your time

Murray

May 30, 2019 at 2:46 am #3919933

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

No problem, WordPress issues can be complex, but in this case I am sure the Theme Fusion Support will be able to assist you quicker than us.

It might be that there is an opening or closing tag [] for the shortcodes missing or some other typing error.

I would advise you to leave them a message and let them know that this issue occurs in minimal setup.

Kind regards
Andreas

May 30, 2019 at 2:53 am #3919943

murrayB

I decided to copy over my french-language page and replace the text with English, effectively creating a fresh home page, and it worked! I must have messed something up with my initial translation attempt, it's working as it should now!
Thanks again for your help.