This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by emilioM-10 8 months, 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
November 17, 2018 at 9:16 pm #2916422

emilioM-10

Tell us what you are trying to do? I'm trying to install with no success the wplml plug-in into mysite developed with flatsome child theme with siteground server provider.

During installation process i stopped at the "translation languages" and I'm not able to go ahead until the end of the WPML installation.

Is there any documentation that you are following? The WPML official documentation. I have installed right all four ".zip" wpml package into my site

Is there a similar example that we can see? No. Unfortunatelly for me it is the first time that i'm using WPML plug-in.

What is the link to your site? hidden link

Please help me to solve this issue. It is very important to have WPML for my customer.
Thanks in advance, BR
Emilio

November 18, 2018 at 12:24 pm #2917292

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Emilio,

Thank you for contacting WPML support.

Please try to install the WPML Multilingual CMS first. Then install the rest.

And, you might be experiencing compatibility issues. So to make sure if possible, please do the following steps.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

November 18, 2018 at 4:33 pm #2917609

emilioM-10

Hi riffaz,
unfortunatelly the problem is still present.
I have disinstalled all four plug-in of WPML and i reinstalled back them, first WPML core (as suggest by you) and after that i installed the rest of WPLM plug-in.
During the installation phase I found some message errors in the dashboard of wordpress. Here below i put some screenshoot image also "debug.log" file (as suggest by you).
I have tried also to deactivate all the pug-in present in my wordpress core but the problem with WPML installation is still present. I'm using a child theme of flatsome.
Here in attach i also put a screenshoot of console error of my website (i saw a red error related to wpml installation). Let me know if you need an admin access for some your investigation. I hope to use this WPML plug-in for my ecommerce site. Thanks in advance. BR /Emilio

November 18, 2018 at 4:39 pm #2917658

emilioM-10

Sorry
i'm not able to send you the "debug.log" file (here inattach is only possible to send an image file).
Let me know how can send it yo you.

Br Emilio

November 18, 2018 at 4:51 pm #2917661

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Emilio,

Let us know your site login details to check this closely.

I am setting the next reply as private.
So only you and I can see the next reply.

Regards,

November 18, 2018 at 4:52 pm #2917662

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

*** setting the next reply as private.

November 19, 2018 at 1:15 pm #2919575

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Emilio,

Thank you for the updated details.

WPML is missing some records in the languages tables and Some are corrupted.
It cannot fully work until this issue is fixed.

This could happen because of incomplete installation, poor internet connection or some plugin incompatibility, etc..

Please follow these steps:

1. Disable all the third party plugins (especially the caching plugins.)
2. Delete the WMPML and it's AddOns.
3. Go to your cPanel
4. Find the database of this site.
5. Delete all the tables which has _icl_
6. Install only WPML (WPML Multilingual CMS)
7. Activate
8. install other WPML AddOns and activate then install and activate the third party plugins.

Let me know the results, please.

Regards,

November 19, 2018 at 3:44 pm #2920354

emilioM-10

Hi,
all clear, i will do it as soon as possible and i will inform you about WPML installation. Just one question: you told me to find in the database the table with "_icl_", i checked and i found four records in the "wp_option" and two records in the "wp_post". I only need to delete this record under both folder (wp_option and wp_post) or there's some other table that i need to find and delete in my database? Thanks in advance. BR

November 20, 2018 at 8:09 pm #2924671

emilioM-10

HI Riffaz,
I done step by step very very carefully and now the installation of WPML is completed but with some errors related to "missing some records in the language" (please see the screeshot in attach).
Currently only WMPL's plug-in is acive and running into my site all rest of plug-in are disabled. Please could you help me to solve this WPML errors?
Another info: I have set four language for translation (Italian is default, english, detush, french and spanish) and in the "top bar menu" I have put the switch languages but i don't understand the way for to change the languages that i have set when i click the "flag at the top bar menu.
My final goals is to give my customers all content of my site into the four languages I set up (give them the possibility to choose the avaiable languages from top bar menu) but i don't understan how to do it. Waiting for your answer. Thanks in advance. BR /Emilio

November 21, 2018 at 5:27 am #2925471

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Emilio,

Glad it worked.

Please ask your every new question in a new ticket to avoid the confusion.
We are happy to help 🙂

Since the initial question of this ticket has already been answered and solved please open a new dedicated ticket for the other question.

Anyhow, for the other issue:
Solution:
- Deactivate all non-WPML plugins.
- Reset WPML by following the steps below:
WPML >> Support >> Click on troubleshooting page link >> Scroll down to the end of the page >> Choose I am about to reset all translation and language data >> Click Reset

Please note that this solution works with WPML new installation only, since the reset option will delete all WPML tables and accordingly any translations you have on your website if you have any.
-Reactivate all non-WPML plugins

If this does not work please open a new ticket with your second question.

Regards,

November 25, 2018 at 7:05 pm #2937977

emilioM-10

My issue is resolved now. Thank you!