This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Raja Mohammed 8 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
January 21, 2019 at 3:44 pm #3113083

Steve Lettau

Tell us what you are trying to do? Edit pages in the non default language (German) but all the Divi Theme buttons are also in German (i.e. Save, Copy etc) I'm trying to figure out how to to have this appear in English

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? wiedplas.com

January 22, 2019 at 9:01 am #3115216

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Steve,
Welcome to our forum, I will be handling your ticket.

You can choose the backend language for each user
1) Go to Edit Your Profile->Set language as your preferred language.
2) On the same page under WPML language settings make sure the option "Set admin language as editing language." is not selected.

After updating these settings you will be able to use the language switcher to switch between your languages in the backend.

Please let me know if you need any further assistance.

Kind regards,
Raja

January 22, 2019 at 6:57 pm #3117915

Steve Lettau

Raja, I have followed above instruction and problem remains. I did disable WPML String Translations plugin and all is ok. So ... I believe it is in some of my string translations. Can you help me determine which ones I need to remove?

January 22, 2019 at 7:18 pm #3117976

Steve Lettau

Raja, I can provide you with access to the staging site upon your request.

January 23, 2019 at 5:52 am #3119030

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Steve,

Yes please provide us with temporary access with administrative privilege, I have enabled the private fields to securely share the details with us. Let me have a detailed look in to the issue.

Kind regards,
Raja

January 24, 2019 at 6:58 am #3123576

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Steve,

Sorry, I thought you need that for the backend. Since the frontend doesn't take the language option set in the backend, I can provide you with two solutions for your issue, there is no straight forward option kindly choose whatever works best for you.

1) Delete 'et_builder' domain strings from string translation

Recommended: Backup your site and database

Perform the below steps in WPML > String translation page.
- Scroll down to " Auto register strings for translation section " click on edit and uncheck the domain "et_builder"
- Select the domain 'et_builder' from domain dropdown filter
- Select all the string of 'et_builder' domain and hit Delete selected string
- perform the operation until all the strings of the et_builder domain is deleted
- Make sure you have selected the option "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" in WPML > Theme and plugins localization > Localization option
- Once done all with this DO NOT register the strings of the et_buider domain again

2) Copy English strings to the German translation for et_builder domain

This is work intensive If the above option does not help you can try this.
- Go to WPML >> Theme and plugins localization
- Enable the "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" option
- Go to WPML >> String Translation
- Search for the affected strings (eg. Themes, Dashboard)
- Select the "Complete Translation" checkbox for all the translations of those string as in the attached screenshot

Let me know the results,

Kind regards
Raja