This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by revofrance 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 22, 2018 at 3:40 pm

revofrance

I am trying to:
Translate a Gravity Form

I expected to be able to translate and save to 100%, but it stays stuck at 48% and doesn't want to save the rest.

September 24, 2018 at 9:50 pm #2761854

Ricardo Alday

Hi,

Thank you for contacting WPML support.

You should increase the max_input_vars limit of your PHP. You can use php.ini or .htaccess if your host allows.

=> php.ini file

Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link

=> .htaccess file

php_value max_input_vars 10000

Let me know if that helps,
Ricardo

September 25, 2018 at 11:32 am #2763498

revofrance

Hi, tried that, here is my ini file:
max_input_vars = 10000
upload_max_filesize = 1000M
post_max_size = 2000M
memory_limit = 3000M
file_uploads = On
max_execution_time = 180
register_globals = on

It didn't work...

September 25, 2018 at 4:09 pm #2764716

Ricardo Alday

Is it ok with you if I install the Duplicator plugin to get a clone of your site to run some tests locally?

September 26, 2018 at 1:05 pm #2767347

revofrance

Yes, sure

September 27, 2018 at 5:44 am #2769352

Ricardo Alday

Thanks. I downloaded a copy of your site and ran some tests.
It's definitely the max_input_vars value. I ended up setting it up to 60000 to get the form to finally translate all. Give it a shot and let me know if it works.

October 6, 2018 at 7:48 pm #2793081

revofrance

Hi, changed it first to 60000 then to 100000 as you can see here: hidden link

But to no avail... What can I do, it still does not save the form more than 35%

October 8, 2018 at 3:05 pm #2796535

Ricardo Alday

Increase the memory limit to 256MB and let me know if it helps.
Apart from that, your PHP settings are pretty much the same as mine.

October 10, 2018 at 6:41 pm #2805459

revofrance

Increased Memory Limit to 256 🙂 Still doesn't work 🙁

October 10, 2018 at 10:14 pm #2805917

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Ricardo is off at this moment. I would like to take care of your ticket from now.

When I try to connect to the dashboard, "Internal Server Error" appears. I'll attach an image for you to see.

Also, by accessing the link you posted earlier (hidden link), I noticed that the memory is still as 128Mb (you can look for memory_limit).

Please, could you check this issue in the backend so I can check the problem? Your next answer will be private.

Thank you.

October 11, 2018 at 7:48 am
October 12, 2018 at 2:09 am #2810201

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. Unfortunately, it looks like both the memory and the "max_input_vars" are not yet configured correctly.

When I access your site and click on the WPML > Settings, I see that you are still using the "max_input_vars" with the value of 1000 and the memory, with 40Mb. I'll attach an image for you to see. As I do not have access to FTP, I can not seem to try setting this up.

Please, could you try again to increase these limits and then check if these values have actually changed? After that, try translating the form again and see if the problem persists.

Thank you.

October 12, 2018 at 8:22 am #2811161

revofrance

Hi, sorry, my bad, thought that having the php.ini in the root folder meant it would apply to all subfolders, but I moved it to wp-admin folder and then it worked. Thanks for the help!