This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Laura 4 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
April 19, 2019 at 11:03 am #3645225

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

as I told in a previous post, I can't work on your copy of the site - I don't know if the migration failed or if there are other errors.
Can you add your credentials so I can take a Duplicator of your site directly? I'll enable a private reply.

April 23, 2019 at 12:56 pm #3664113

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I tried to get a Duplicator, but due to hosting constraint I couldn't get one, nor I could download files via FTP. I also noticed you have some peculiar configuration (I couldn't find the wp-content folder, not I can see where you store your plugins). I don't know if this could be related to your issue.

I set the variation to fallback to default language, but it seems it's not working.
I noticed, however, that not all attributes are available for translation so probably this is why the issue happens.

As a possible workaround, I would suggest duplicating your products since it works with translated products.
If you don't wish to duplicate, I would need a working backup from you, with instruction on how to install it since it's not a standard WordPress installation.

April 23, 2019 at 1:28 pm #3664305

HansonB

Hello Laura,

The theme and plugins store in the storedata folder. I changed it at very first time for security.

I remember the issue and the similar has existed for a long time. That's why there are older product that I have the duplication even it hasn't translated.

I can definitely duplicate the post, but if you would like to solve the problem. Then please let me know. For sure, if it can be fixed that will be better.

Sincerely,
Hanson

April 24, 2019 at 3:02 pm #3674465

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I consulted with a 2nd tier and it should be possible to display variation even with the fallback option. If you always had this issue it may be due to a theme or a 3rd plugin incompatibility.

As I said in my previous post, I cannot download your plugins via FTP, I receive a timeout error after 20 seconds. Therefore, I don't have a copy of your site I can test.
Would you be able to create a backup I can test or at least provide me a .zip file with theme and plugins? If so, please upload it somewhere and share the link with me, I'll enable a private reply.

The topic ‘[Closed] I'm using the latest WPML, but the WooCommerce Variations is missing on new post’ is closed to new replies.