Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Lauren 7 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
December 7, 2018 at 12:46 pm #2977913

rufusB

I am trying to: Reinstate the image captions

Link to a page where the issue can be seen: hidden link

This issue emerged yesterday prior to the wordpress update but it persists including using backups. It may be related to moving images on the page.

The captions are all showing in the English page. The majority have disappeared from the translated custom captions box and ceased to display in the translated page. When they are added to custom captions I cannot save them using elementor.

The page strings have been checked and are up to date.

I noticed that in the WPML > Media Translation interface image captions are all listed as untranslated and remain so even after they are edited.Ii have experimented using the advanced, classic and manual translations but it's all the same.

December 7, 2018 at 4:27 pm #2978680

rufusB

Just found this which appears to be related to elementor translations. I t will not allow me to enable the translation editor.

December 10, 2018 at 1:06 pm #2984327

rufusB

A new problem emerged which prevented me from accessing product pages backend, to edit them. I received-

f you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

Common reasons for this error are:

Incorrect file/directory permissions: Above 755.
In order files to be processed by the webserver, their permissions have to be equal or below 755. You can update file permissions with a FTP client or through cPanel's File Manager.

Incorrect Apache directives inside .htaccess file.
Make sure you have not specified unsupported directives inside the local .htaccess file. Such include PHP settings and Apache module settings.

The culprit is the WPML string translator plugin which does not work with any theme I have trues, same result. For now, I have deactivated it and am able to add captions to images again.

December 10, 2018 at 3:12 pm #2985000

rufusB

New related issue, WPML CMS disables Yoast content optimiser.

December 10, 2018 at 7:03 pm #2985830

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Per our support policy, we need to isolate each ticket to one main issue. So in regards to the error log and the Yoast content, please open a separate ticket for each issue.

As for Elementor issues, we released an update today that resolves some Elementor issues. Please update to WPML 4.1.2 and then update the page in the original language. Then, edit using the translation editor. Now are the captions available for translation?

I also see that you are using multiple Elementor add on plugins. Are these custom caption elements created by one of the plugins, or are they part of the Elementor core content?

December 11, 2018 at 10:36 am #2988106

rufusB

Hi Lauren, my WPML hasn't updated to the new version and neither have I been able to update it manually. Not sure what's going on there, I'll try uninstalling then starting from scratch.

I'm not sure what part of elementor is used for the captions, I'll test that in a bit.

December 11, 2018 at 11:08 am #2988317

rufusB

Hi again, the captions are a function of basic elementor. i don't want to completely uninstall CMS as apparently I'll lose all my settings so I might need a hand with that please.

December 11, 2018 at 6:20 pm #2989921

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

To upgrade WPML, please go to Plugins -> Add New and click the Commercial tab. On this page, click check for updates. Then you should see the available WPML plugin updates that are available.

If you do not see any updates, please download the latest version from http://www.wpml.org/account/downloads. Then, deactivate and delete your existing WPML plugins and install the new one. You should not lose your settings.

Please let me know the results once you have the latest version.

December 11, 2018 at 7:57 pm #2990218

rufusB

Thanks, that's now upgraded but the string translator is still hiding captions and blocking access to the product backend.

December 11, 2018 at 8:38 pm #2990305

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

December 13, 2018 at 8:32 pm #2999418

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending files. Unfortunately, I was not able to create the copy of your site because the duplicator file was corrupt.

However, I realized that you are editing the translated page using manual translation and I think may be part of the issue. Elementor content should be translated using the Translation editor. So, I switched your site to use the translation editor (in WPML -> Settings) and updated the original page. Now, I can see the captions to be translated however in the browser console I'm getting some errors. It looks like the server is configured to disallow iframes from other domains, and you are using languages in multi domains. This may be a server configuration issue.

You can override the header with specific values, for example, for apache:

Header set X-Frame-Options "ALLOW-FROM hidden link"

(You should replace those urls with the ones from the site)

In this link you will find more information about this subject: hidden link

If this does not resolve the issue for you, please try using the All In One Migration plugin to create a copy of your site. I have marked the next reply as private in case you need to share the export file with me.

December 16, 2018 at 2:13 pm #3005698

rufusB

Hi, thanks for taking a look.

Firstly I need to tell you, I don't speak Headers, X-frame, click jacking etc, it's all way over my head, I'm afraid, so I'm not going to mess with what I will probably destroy.

I'm not entirely sure, but I have a feeling that translations may have been set to manual by another support worker some time ago, to sort another problem. All the same, I'm not convinced this is the issue, it all used to work just fine before the updates which initiated several problems, with the theme as well as WPML.

There are issues, usually delays, implementing elementor styles on other pages but the captions that disappear are only from this page hidden link I can't see how it is differently configured from other captioned pages but notice that the captions that DON'T disappear, are all fairly recent, from a similar work period.

After deactivating the string translator I manually reinstated the captions but they've gone again, probably as I am constantly (de)activating the string translator to work around the current difficulties. If they are back when you next look, it will be because I've re-added them manually. I am unable to reinstate the captions using the translation editor and it's only by de-activating the string translator that i can access an English language product page to create and edit it or to add captions and save them.

Unfortunately, All In One won't export the site. Would you be able to work from backup files?

December 16, 2018 at 3:01 pm #3005777

rufusB

Further to the above, I just edited another translated elementor captioned page through the translation editor with string translator active and lost the captions. The original page had the elementor style issues mentioned above (no bold type, no border or entrance animation) but when I deactivated the string translator and manually reinstated the translated captions, the style automatically corrected in the original page. Unfortunately, I need the string translator to activate features like the currency switcher.

December 16, 2018 at 3:07 pm #3005784

rufusB

"but when I deactivated the string translator and manually reinstated the translated captions, the style automatically corrected in the original page. "

This doesn't happen on all pages.

December 16, 2018 at 3:17 pm #3005803

rufusB

Regarding the images which have retained their captions, although they are set to custom captions, they are in fact taken from the attachment caption.