This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 42 replies, has 2 voices.

Last updated by Lauren 5 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
December 21, 2019 at 4:10 pm #5175869

rufusB

I don't even see this on your known issues list.

December 23, 2019 at 7:20 pm #5186035

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was just updated that this issue is now resolved. I tested with a clean install with our latest versions and the custom caption shows in the translation editor and displays correctly on the front end. Feel free to login here to the staging site to see it working: hidden link

That link should log you in, and you can see the example here:
hidden link
hidden link

Can you please create a new test page on your site with our latest updates and let me know if it is still happening there?

December 23, 2019 at 8:52 pm #5186187

rufusB

Oh well, maybe Christmas came a few days early this year. I've tested on the staging site and it seems to work. Where do I find the update for my site?

December 24, 2019 at 9:38 pm #5190525

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To update automatically, you can go to Plugins -> Add New and click on the Commercial tab. Then click "Check for Updates" and you should see the available updates. You can install right from this page.

Please let me know if this resolves the issue for you.

December 24, 2019 at 10:03 pm #5190555

rufusB

I don't see any updates since 10th December, all of which are up to date.

December 27, 2019 at 1:35 am #5197391

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

if you are using the latest versions of WPML plugins, please try creating a new test page with an image and custom caption, and see if you are able to translate it. If not, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

December 27, 2019 at 10:39 pm #5202153

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I see you are using an out of date version of Elementor Pro. On my test site, I am using Elementor 2.5.8, but there is an even newer version. Please update to the latest version and let's see if that resolves the issue. Thanks!

December 27, 2019 at 11:13 pm #5202227

rufusB

I'm no longer subscribed to Pro so no update. I did, however, deactivate it and the error persists.

December 30, 2019 at 8:35 pm #5212903

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that. I installed a copy of your site locally where initially I saw the issue. I then deactivated all non WPML plugins and switched to a default theme, then saved the page and updated the caption translation via translation editor. After these steps, the correct translation displayed on the frontend. I then reactivated the theme and all plugins, and it still showed the correct translation. So it seems there may be a conflict with another plugin that is blocking the translation. Would it be possible for you to test these steps on your live site?

December 30, 2019 at 11:51 pm #5213207

rufusB

I just tested that with twenty twenty theme and all plugins deactivated except WPML Media, CMS, String and Translation, plus Elementor. Unfortunately same result at my end.

January 6, 2020 at 5:57 pm #5241889

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I set up a copy of your site locally for further testing. I found that when I disable WPML Media Translation, then update the original custom caption and the caption translation, the correct translation displays on the front end. Could you try this on your live site?

I was not able to reproduce this issue on the clean install. So if this is working on your live site only with Media Translation deactivated, perhaps try activating Media Translation and then deleting one of the images and re-upload a fresh copy of the image. With a new image, does the custom caption display correctly?

January 7, 2020 at 12:48 pm #5246739

rufusB

The first part worked which shows that elementor custom captions are preserved by deactivating either string or media translator when updating a page. Replacing the image with media translator active didn't work though.

The root of the problem lies somewhere I don't know about. If I update the string translations of a page or translate a page from Pages>page name>update translation with both these wpml plugins active, this also removes custom captions. I also notice that elementor custom captions fields are still used, it's just that they draw their content from somewhere other than the translated page builder. Clearly, although editing strings removes the captions you customise, the string translator is not where the image captions are stored, the translated strings remain correct.

There are also "catastrophic events," perhaps wordpress or woocommerce updates, which periodically replace custom captions for the entire site. Didn't you mention earlier that custom captions are stored elsewhere?

I can't see beyond the user interface but I notice that with all plugins active, the text editor field in the attached is editable here, while the captions are not. Probably irrelevant, I also notice the image link url appears for translation. This is an obsolete url. Now I've updated it, it is no longer available to translate.

January 8, 2020 at 4:17 pm #5255637

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing this as well. I have escalated this back to our 2nd tier since I am unable to reproduce the issue in a clean install. I will update as soon as we have more information.